Ask Your Question
0

Fedora 29 install errors

asked 2018-10-30 17:54:04 -0500

AfaMobius gravatar image

updated 2018-10-31 01:12:35 -0500

villykruse gravatar image

I tried to upgrade fedora28 to fedora29 and got some errors ,and then I checked a question another person posted here about VLC and it looks like it fixed the problem by installing the testing update , but now there is 2 errors when i do the upgrade refresh

> sudo dnf upgrade --refresh
[sudo] password for user: 
Fedora 28 - x86_64 - Updates                    242 kB/s |  26 MB     01:48    
Failed to synchronize cache for repo 'nodesource', disabling.
Failed to synchronize cache for repo 'rpmfusion-nonfree-nvidia-driver', disabling.
Last metadata expiration check: 0:00:00 ago on Tue 30 Oct 2018 09:59:25 PM WET.
Dependencies resolved.
Nothing to do.

Complete!

EDIT : tried again and it gave me more errors

> sudo dnf system-upgrade download --releasever=29
Before you continue ensure that your system is fully upgraded by running "dnf --refresh upgrade". Do you want to continue [y/N]: y
Fedora 29 - x86_64 - Updates                    453  B/s | 257  B     00:00    
Failed to synchronize cache for repo 'rok-cdemu', disabling.
Failed to synchronize cache for repo 'fedy', disabling.
Last metadata expiration check: 0:00:00 ago on Tue 30 Oct 2018 10:48:11 PM WET.
Error: 
 Problem 1: problem with installed package libplacebo-0.4.0-1.fc28.x86_64
  - libplacebo-0.4.0-1.fc28.x86_64 does not belong to a distupgrade repository
  - nothing provides libshaderc_shared.so.1()(64bit) needed by libplacebo-0.6.0-2.fc29.x86_64
 Problem 2: package cdemu-daemon-3.2.1-1.fc28.x86_64 requires libmirage.so.11()(64bit), but none of the providers can be installed
  - libmirage-3.2.0-1.fc28.x86_64 does not belong to a distupgrade repository
  - problem with installed package cdemu-daemon-3.2.1-1.fc28.x86_64
 Problem 3: package jdk-11-2000:11-ga.x86_64 requires /bin/basename, but none of the providers can be installed
  - coreutils-8.29-7.fc28.x86_64 does not belong to a distupgrade repository
  - problem with installed package jdk-11-2000:11-ga.x86_64
 Problem 4: package coreutils-8.29-7.fc28.x86_64 requires coreutils-common = 8.29-7.fc28, but none of the providers can be installed
  - package jre1.8-1.8.0_181-fcs.x86_64 requires /bin/basename, but none of the providers can be installed
  - coreutils-common-8.29-7.fc28.x86_64 does not belong to a distupgrade repository
  - problem with installed package jre1.8-1.8.0_181-fcs.x86_64
 Problem 5: problem with installed package vlc-3.0.5-4.fc28.x86_64
  - package vlc-3.0.5-3.fc29.x86_64 requires libplacebo.so.6()(64bit), but none of the providers can be installed
  - vlc-3.0.5-4.fc28.x86_64 does not belong to a distupgrade repository
  - nothing provides libshaderc_shared.so.1()(64bit) needed by libplacebo-0.6.0-2.fc29.x86_64
 Problem 6: problem with installed package lutris-0.4.21.1-6.1.noarch
  - package lutris-0.4.21.1-6.1.noarch requires python(abi) = 3.6, but none of the providers can be installed
  - python3-3.6.6-1.fc28.x86_64 does not belong to a distupgrade repository
 Problem 7: package vlc-core-3.0.5-3.fc29.x86_64 requires libvlc_vdpau.so.0()(64bit), but none of the providers can be installed
  - problem with installed package vlc-core-3.0.5-4.fc28.x86_64
  - package vlc-3.0.5-4.fc28.x86_64 requires vlc-core ...
(more)
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2018-10-30 21:43:01 -0500

SteveEbey73701 gravatar image

same issue. removed vlc, and it removed the missing library. upgraded. tested all the stuff after upgrade. To reinstall vlc i ran sudo dnf config-manager --set-enabled updates-testing, then sudo dnf install vlc then ran sudo dnf config-manager --set-disabled updates-testing so that other updates would only come from stable and not testing repo. Or you can just wait till the libplacebo is moved from testing to stable. Up to you.

edit flag offensive delete link more
1

answered 2018-10-30 21:40:52 -0500

AfaMobius gravatar image

I solved the problem , I removed every package that was displayed in "Problem NUMBER package PACKAGENAME" , I used the simple command : dnf remove PACKAGENAME

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-10-30 17:07:37 -0500

Seen: 2,135 times

Last updated: Oct 31 '18