Ask Your Question
0

Xfce menu doesn't show Flatpak apps

asked 2018-11-07 08:13:21 -0600

hroncok gravatar image

I have Fedora 29 with Xfce.

I decided to install Inkscape from flatpak:

$ sudo dnf remove inkscape
$ sudo dnf install flatpak
$ flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
$ flatpak install flathub org.inkscape.Inkscape

I can run Inkscape via flatpak run org.inkscape.Inkscape but I don't see it in the applications menu.

The desktop file is at /var/lib/flatpak/app/org.inkscape.Inkscape/current/active/files/share/applications/org.inkscape.Inkscape.desktop yet the menu ignores it. How do I "teach" Xfce to show flatpak apps?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-11-07 08:47:48 -0600

hroncok gravatar image

So apparently all I needed to do was restart Xfce (log out and log back in).

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-11-07 08:13:21 -0600

Seen: 34 times

Last updated: Nov 07