Flatpak installed Inkscape doesn't respect my GTK theme

asked 2018-11-07 08:49:03 -0600

hroncok gravatar image

updated 2018-11-07 09:59:28 -0600

I have Fedora 29 with Xfce. I use the Greybird theme.

I decided to install Inkscape from flatpak:

$ sudo dnf remove inkscape
$ sudo dnf install flatpak
$ flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
$ flatpak install flathub org.inkscape.Inkscape

When I run Inkscape, it looks like Windows 95. See attached screenshot of flatpak Inkscape vs. dnf installed Inkscape.

How do I make it look "normal"?

screenshot

Note: When I set the GTK theme to Adwita, the Flatpak Inkscape respects it. It just shows the "default" theme when I have Greybird set.

edit retag flag offensive close merge delete

Comments

This may be more of an Xfce issue than a Fedora problem. Try asking at the Xfce Forum as well and see if they have any suggestions.

sideburns gravatar imagesideburns ( 2018-11-07 10:49:18 -0600 )edit

@ I think Is the version of Inkscape install it via dnf work's and flatpak doesn't work is a faltpak packed problem (some problem find configuration files in flatpak) I Know it because I've had problem with atom install it via flatpak, regards.,

hhlp gravatar imagehhlp ( 2018-11-07 10:57:20 -0600 )edit

as far as I understand, you will have to install the icon theme separately: there is: org.gtk.Gtk3theme.Greybird (flatpak search greybird).

florian gravatar imageflorian ( 2018-11-07 11:15:13 -0600 )edit

That doesn't fix the problem, Inkscape uses GTK2.

hroncok gravatar imagehroncok ( 2018-11-07 11:34:50 -0600 )edit
1

I've opened a Flatpak issue https://github.com/flatpak/flatpak/is...

hroncok gravatar imagehroncok ( 2018-11-08 06:24:42 -0600 )edit