Ask Your Question
1

Upgrade to 29 fails: reboot and select proper boot device

asked 2018-11-07 14:58:11 -0600

Jordy gravatar image

Past years upgrades worked perfectly on my system. Fedora is installed on my Intel M.2 SSD and got upgraded every time starting from 25. There where never any upgrade problems.

But when ik tried to upgrade from 28 to 29 today my system fails. On reboot i got the message "reboot and select proper boot device".

Looking in my BIOS showed 2 boot devices. On called "(IntelSSDM2xxxxx)" and one called "Fedora (IntelSSDM2xxxxx)". Strange, since it's the same SSD! If i choose the first, the system just boots BIOS again. If i choose the last, it just gives the same error.

Choosing UEFI or Legacy also doesn't help. What can i do? is there a recovery or something? (Sry, bit of a OS n00b)

edit retag flag offensive close merge delete

Comments

If the bios has detected your boot disk successfully, and you have tried to change the boot disk, but no luck, try to reset primary partition as active. First, insert the Windows installation media and boot your computer from that, then under System Recovery Options or Troubleshoot, click Command Prompt, type the following commands and hit enter after each: diskpart -> select disk 0 -> list partition 1 -> active. If this does not work,either, then MBR might be damaged, you need to repair MBR.

emily7772 gravatar imageemily7772 ( 2018-11-12 19:24:10 -0600 )edit

Above comment can be considered advertising

florian gravatar imageflorian ( 2018-11-14 09:11:34 -0600 )edit

Besides that it is even quite wrong. We're talking EFI here, there is no MBR at all. Glad the op solved his problem.

ed209 gravatar imageed209 ( 2018-11-14 12:09:28 -0600 )edit

Upvote the OP!

florian gravatar imageflorian ( 2018-11-14 13:16:21 -0600 )edit

Thanks guys :)

Jordy gravatar imageJordy ( 2018-11-15 10:03:04 -0600 )edit

3 Answers

Sort by » oldest newest most voted
1

answered 2018-11-14 08:29:44 -0600

Jordy gravatar image

updated 2018-11-14 08:30:31 -0600

Oke, finally solved the puzzle... First, using USB live media & a USB bootloader, i managed to find a problem (corrupted) /boot/efi partition. Long story short, i followed the these steps:

  1. unmount /boot/efi
  2. format /boot/efi (nvme0n1p1) partition with FAT32
  3. Started Fedora by USB Bootloader
  4. Re-installed GRUB with new config
  5. Cleaned EFI menu, removing old entries

After this, the machine stalled at loading job (90sec. wait) and entered emergency mode. From here i updated /etc/fstab with the new UUID of /boot/efi partition, since it changed when formatted.

This solved the problem :) Thanks for pointing directions guys!

edit flag offensive delete link more
1

answered 2018-11-08 13:01:56 -0600

Jordy gravatar image

updated 2018-11-09 04:07:31 -0600

When i insert a fedora Live media USB, and navigate to "reclaim disk space", i see the following:

  • 119.2 GiB INTEL SSDPEKKW128G7 (nvme0n1)
    • /boot/efi (Fedora Linux 29 for x86_64) (nvme01n1p1 - EFI System Partition)
    • /boot (Fedora Linux 29 for x86_64) (nvme01np2 - ext4)
    • fedora (nvme0n1p3 - physical volume LVM)

I'm no expert on fedora and especially booting, but to me it seems like 2 boot partitions? What can i do?

edit flag offensive delete link more

Comments

You don’t have two boot partitions. You have a boot partition that is mounted to /boot and you have a boot loader partition that is mounted to /boot/efi. Everything looks normal here. You need to leave your system on UEFI mode! Problem is rooted elsewhere.

florian gravatar imageflorian ( 2018-11-08 13:40:13 -0600 )edit

Something is badly broken. Partitions named nvme01n1p1 i.e. first partition on device nvme01n1 cannot exist. nvme devices and its partitions are named differently.

ed209 gravatar imageed209 ( 2018-11-08 17:46:13 -0600 )edit

@florian, if partitions are ok, is there a way to only re-install the boot/loader part? @ed209, maybe you are right, but i can find multiple items called the same when searching the Internet. What is it supposed to be named? (and, can i change that kind of naming)?

Jordy gravatar imageJordy ( 2018-11-09 04:23:41 -0600 )edit

I am right for the simple reason that nvme devices are named nvme0n1, nvme1n1 and so on. The corresponding partitions are named nvme0n1p1, nvme0n1p2 for the first drive, nvme1n1p1, nvme1n1p2 for the second drive and so on. Not the way you see it. Something strange is going on.

ed209 gravatar imageed209 ( 2018-11-09 04:51:09 -0600 )edit

Oke, thanks for your answer, i will re-check my hardware and if necessary get a new SSD. Other then that, is it possible to copy the content of my (old) SSD and use that on a new device with only installing a boot/loader? Or something like that?

Jordy gravatar imageJordy ( 2018-11-09 06:00:16 -0600 )edit
0

answered 2018-11-07 17:02:55 -0600

ed209 gravatar image

Since it's your BIOS that shows two boot devices, that is your hardware, what has this to do with Fedora? Are you sure your hardware is OK? What about the drive? How did you upgrade? Have you upgraded your bios?

edit flag offensive delete link more

Comments

Honestly, i don't know for sure there was only one boot devices before updating. The system did run perfectly for 2 years.I did a complete update before upgrading: sudo dnf update, sudo dnf upgrade --refresh, sudo dnf install dnf-plugin-system-upgrade & sudo dnf system-upgrade download --releasever=29

In between i did a reboot twice, just to be sure, and there was no problem booting then. After running: "sudo dnf system-upgrade reboot" via remote terminal, the connection disconnected (obviously) but wouldn't get up again. Once home i connected a monitor and saw this error. no hardware changed

Jordy gravatar imageJordy ( 2018-11-07 17:40:25 -0600 )edit

Again, and for the last time. Is it your BIOS that shows two devices, as previously stated?

ed209 gravatar imageed209 ( 2018-11-08 17:43:30 -0600 )edit

Yes, in my BIOS i can choose from 2 (the same) devices. One of them which has the prefix "Fedora".

Jordy gravatar imageJordy ( 2018-11-09 04:06:40 -0600 )edit

So your bios actually shows two identical devices. Something is wrong with the hardware. Check out the hardware first.

ed209 gravatar imageed209 ( 2018-11-09 04:48:21 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-11-07 14:58:11 -0600

Seen: 119 times

Last updated: 2 days ago