Ask Your Question
0

Having to always reset permissions on folders

asked 2018-11-08 04:08:23 -0600

Orriginal gravatar image

Been using Fedora 28 for a while now but I seem to have to always reset permissions on folders on a 2nd Hard disk to be able to edit files...Which, I am sure you can understand is a pain in the ...................

I am using sudo chmod -R ugo+rw folder name

It works for one time but the next time I try and reopen the same file, It is always in READ ONLY mode.

Please help...Am I doing the command wrong ? Thanks in advance

edit retag flag offensive close merge delete

Comments

How do you mount the drive?

florian gravatar imageflorian ( 2018-11-08 04:38:00 -0600 )edit

Are there errors in logs about failing hard disk? That would turn the complete hard disk into read-only mode.

johanh gravatar imagejohanh ( 2018-11-08 05:57:55 -0600 )edit

The drive is mounted automaticly at boot.... I'll check the Logs Hadn't thought about that !! DOH

Orriginal gravatar imageOrriginal ( 2018-11-08 09:55:03 -0600 )edit

OK, I cannot find anything specfic to tthat Drive..but I'll disable the auro mount and see what happens..thanks for the Idea

Orriginal gravatar imageOrriginal ( 2018-11-08 10:02:08 -0600 )edit
1

Florian - YOU GOT IT..thank you..Was a Mount error ;-) THAKN YOU

Orriginal gravatar imageOrriginal ( 2018-11-08 10:35:39 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-11-08 10:10:48 -0600

ed209 gravatar image

It usually happens either when you don't mount the drive in a proper way or when the disk is failing. How do you mount it and what is the disk status?

edit flag offensive delete link more

Comments

YUP, as was mentioned earlier...unknown to me there was an error on mount...not listed in Log files BUT I removed the mount command and booted...added it back and now seems ot be OK...Not to surw what happened but it works again..thanks ;-)

Orriginal gravatar imageOrriginal ( 2018-11-08 10:37:20 -0600 )edit

I bet the directory under which you mounted the drive had wrong permissions and was owned by root, not by your username. That would explain everything.

ed209 gravatar imageed209 ( 2018-11-08 11:35:44 -0600 )edit

OK, I was mounting it under the /mnt folder...I'll move it to home and see if thta changes it....

Orriginal gravatar imageOrriginal ( 2018-11-09 03:00:34 -0600 )edit

So, with the Drive mounted under the home dir, I can access the files in read write mode....BUT if I select the files from "recent" in the FILE app...then it always opens in READ ONLY mode.............any ideas ?

Orriginal gravatar imageOrriginal ( 2018-11-09 03:18:26 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-11-08 04:08:23 -0600

Seen: 34 times

Last updated: Nov 08