Ask Your Question
2

Blank screen after log-in in Fedora 29

asked 2018-11-11 06:47:18 -0500

ET gravatar image

updated 2018-11-11 08:22:09 -0500

I'm using Fedora 29, and I installed NVIDIA drivers and CUDA couple of days ago, though everything was working fine. Yesterday, I setup my bluetooth mouse using blueman, and again everything seemed to work fine until last night, when I shutdown the machine. Today when I try to start the machine, it asks me to enter my LUKS password because I have encryption enabled. Then, it loads the login page where I have to write the password for my user, but then after login somehow the whole screen is blank. I wonder what the problem is and how can I investigate it. The screen turns complete blank, I cannot even see the mouse cursor.

When I start the rescue mode, then after it loads I can run journalctl there, and from the response I saw some BIOS related errors, which I attach here. I don't know how relevant they are. I think I also updated the kernel yesterday, but when trying to login using the previous kernel version I still get the blank screen after login. Any ideas what the problem might be and how to further investigate it?

edit retag flag offensive close merge delete

Comments

Is the nvidia driver from an rpm or did you install from nvidia.com? if you installed nvidia.com then did you use dkms to build new modules for the kernel? When you get the blank screen after login, have you tried to CTRL-ALT-F2 to get to a tty console, and login? if you can login, run dmesg and see what it shows.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2018-11-11 07:52:04 -0500 )edit

Yes, the drivers were from NVIDIA webside and I used dkms for the kernel modules. But, I installed the drivers couple of days ago and it was working fine. Once, I enter my LUKS password, it opens the actual GDM login page, where I have to enter my user password. At that moment doing something like CTRL+ALT+F2 doesn't do anything. Once I login, the screen turns blank and again doing something like CTRL+ALT+F2 does nothing. So, I somehow cannot get tty console, I only get normal GDM login on startup.

ET gravatar imageET ( 2018-11-11 07:55:32 -0500 )edit

Btw, the screen turns complete blank, I cannot even see the mouse cursor. I don't know how relevant this is.

ET gravatar imageET ( 2018-11-11 08:22:23 -0500 )edit

at the grub menu, edit the entry with the f29 and put nomodeset=0 on the linux command line, near the quiet entry, to see if that lets you boot low-resolution. if so, then try reinstalling the video driver. adding nomodeset=0 is a one time change, it does not save to that entry, so after you reinstall the video driver and reboot, it will be gone, and you should be good.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2018-11-11 13:45:19 -0500 )edit

I basically put 3 at the end of the line correspond to Fedora in grub, so I booted to tty console, and there once logged in I issued the startx command, and then it seemed to work fine.

ET gravatar imageET ( 2018-11-11 14:05:22 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-11-12 16:49:41 -0500

bt1397 gravatar image
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-11-11 06:47:18 -0500

Seen: 1,072 times

Last updated: Nov 11 '18