Ask Your Question

Keyboard won't work on certain applications

asked 2018-11-11 11:42:42 -0500

mohammadhzp gravatar image

updated 2018-11-11 11:58:11 -0500


I already searched but I couldn't find any solution.

I was doing an offline update and everything seems to go smoothly until my nephew suddenly rebooted before installing updates finishes(about 97%)

After the restart, the system booted up(fedora didn't try to finish that 3% which was left). When OS was ready I tried to type something in any applications(including Gedit, Files, Terminal, Firefox, and Telegram) but it didn't work.

I was only able to press the super key, I tried using Ctrl + Alt + F3 to switch to tty and luckily it worked. Then I entered a few commands(which I don't remember) and somehow I managed to get a few applications working. Applications which works now are Terminal, Files, Gedit. I THINK GTK based applications are working as expected now but other applications such as Telegram(Qt-based application) and Firefox still do not work(I cannot type anything).

On-Screen Keyboard is the same story, it shows only on applications which I am able to write but it doesn't show up in applications like Firefox or Telegram, It's like OS cannot understand(detect) I need to type and it doesn't show the On-Screen Keyboard. One important note to consider is that when I want to type my passcode on the telegram, it shows a reaction(a little animation) but I can't see any characters typing.

I'm almost sure that partial update caused this typing issue.

What can I do to fix it? I don't know anything about how keyboards & input works.

I tried commands like dnf reinstall ibus but it didn't work.

I am using Fedora 29 with Gnome and dnf update returns Nothing to do.

P.S: Currently, I am writing this in Gedit and I have to copy and paste it using the mouse in Firefox

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2018-11-12 07:53:44 -0500

mohammadhzp gravatar image

Alright, It sounds like Clementine caused this issue, I downgraded it and everything is working fine.

This is the version which caused the issue: clementine-1.3.1-30.20181020gitfb00835.fc29.x86_64

I downgraded to clementine-1.3.1-27.fc29.x86_64 and it's working without any issues.

edit flag offensive delete link more


Please file a bugzilla against that version of Clementine.

sideburns gravatar imagesideburns ( 2018-11-12 11:36:49 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2018-11-11 11:42:42 -0500

Seen: 194 times

Last updated: Nov 12 '18