Ask Your Question
0

Fedora 29 KDE : WiFi + KWallet issue durig startup

asked 2018-12-21 17:36:10 -0500

Hi All, I just installed Fedora 29 KDE Spin on my Lenovi Y560 laptop.

WiFi works quiet well, but during startup i notice that it takes a long time for WiFi to get connected. During this period I get a notification stating "No Secrets were provided" After which the WiFi connection deactivates and then reactivates & connects.

I suspect the culprit might be KDEWallet. Just for info I have blank password for KDEWallet so it should not cause any issues.

Can anyone help me figure out what is causing this issue and how can I solve it.

Aplogies if this is a very trivial issue, unfortunately I'm not well versed with debugging linux issues. So any help will be gratly appriciated.

This is a screenshot of the notifications I am receiving during startup.screenshot

regards, Rohan

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-01-16 22:35:14 -0500

psg_nm gravatar image

I have seen the same problem with the Fedora 29 KDE Spin. I agree that integration with KDEWallet is probably involved. As a short term fix I have successfully used two solutions:

  • Following the suggestion https://forum.manjaro.org/t/no-secrets-was-provided-notification/37857:
    1. I right clicked on the WiFi icon the lower right of the screen (the Plasma NetworkManager applet on the panel) and selected "Configure Network Connections...".
    2. On the dialog box that comes up, I selected a WiFi network and then selected the "Wi-Fi Security" tab for that network.
    3. Using the drop-down selection box below the "Password" box on the "Wi-Fi Security" tab, I selected "Store password for all users (not encrypted)".
    4. Of course, you should make sure the right password is entered in the "Password" box, but even with the correct password I had problems using the "Store password for this user only (encrypted)" setting. This seems to suggest that there is some sort of bad KDEWallet integration (or something similar). With the "Store password for all users (not encrypted)" option, I have not been getting the "No secrets were provided" message.
    5. I did steps 2-4 for each WiFi network listed in the dialog box. Oddly I didn't have to re-enter the password that had been stored, just select "Store password for all users (not encrypted)", so clearly it had remembered the password somehow.
  • Also, I suspect that using the "Ask for this password every time" for a WiFi connection for Step 3 above might be another alternative to "Store password for all users (not encrypted)", though, it would not be as inconvenient.
  • The other solution I have tried was to use nmcli command line tool to bring up the link: sudo nmcli -a connection up <name of network>. Note that the -a will cause nmcli to ask for the password for the network, which is really the reason this probably helps. Also note that I did this after using the Plasma NetworkManager applet to select the network and enter a password, so NetworkManager was aware of the network I was trying to bring up. I suspect you need to try to configure a WiFi network connection with NetworkManager first before using the nmcli connection up command to bring the network up. Creating a new network connection can be done with nmcli, but it is probably easier to use the graphical NetworkManager applet provided for Plasma. I needed to run the nmcli command at least once per boot, maybe once per login.

I hope that helps. If I figure out how to get the "Store password for this user only (encrypted)" option to work somehow, I will update his answer.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-12-21 17:36:10 -0500

Seen: 180 times

Last updated: Jan 16