Trouble with Win10 boot after Fedora 29 installation

asked 2019-01-11 07:48:47 -0500

ahesse gravatar image

Hi everyone!

First time posting here (:

To the problem.. I was finally able to install fedora yesterday after quite a while wanting to do it. It works mostly well so far. The only problem I have is when I select Windows in the boot list I get an error and it doesn't work. Should be noted that I AM able to override this by going into the UEFI and forcing it to boot from the Windows drive, then I am able to enter windows without any problems.

So, TL;DR: Installed F29 on a computer with Windows, both on UEFI mode and on completely separate NVMe SSDs. Boot list shows up with 2 entries for fedora (normal and rescue) and one entry for Windows. Fedora entries work fine, Windows doesn't.

====

More detailed description now: I installed Win10-Student-N version on a brand new computer I built myself. Standard installation using Rufus to create the Live Usb (which I believe uses GPT as standard? though I wouldn't know how that affects anything). Windows worked fine. Then for Fedora 29 I used the Fedora Media Writer with the F29 Netinstaller using the automatic LVM partitioning. The reason for this is the computer has a RTX 2080 which was resulting in a blank screen with blinking underscore otherwise. This way I could install Fedora and then install drivers on my own. Anyway, after all this Fedora was installed and working fine. Grub showed 2 fedora entries and 1 windows entry and the fedora ones worked fine. But, when selecting the Windows entry the problems start.

At first when selecting it I would get a black screen with this message:

error: ../../grub-core/commands/search.c:296:no such device: 12A3-B125.
error: ../../grub-core/fs/fshelp.c:258:file `/EFI/Microsoft/Boot/bootmgfw.efi` not found.
Press any key to continue...

At this point I tried going into the UEFI for my motherboard and override the boot order directly to the drive with my Windows installation, doing that succesfully boots Windows without any problem. After searching for quite a while I found a few different suggestions on what to do, even though none matched exactly my problem. First I ran bootinfo which yielded the following https://pastebin.com/izacR2UE.

That didn't help me too much so the next thing I did was copy everything from the Windows EFI boot folder and go to the boot folder on Fedora and paste it there with the path as described in the error. This solved the second error but not the first, so now the error message when picking Windows is only:

error: ../../grub-core/commands/search.c:no such device: 12A3-B125.
Press any key to continue...

I then ran Boot info again and this was the result this time: https://pastebin.com/pBnzmCfd

The last thing I tried was to create a live USB with the Windows installer and try to repair the installation with it's procedure, this did absolutely nothing though (said it failed ... (more)

edit retag flag offensive close merge delete