Ask Your Question
2

Files and folders with name "� (invalid encoding)"; what does it mean and how to fix it?

asked 2019-01-13 06:35:51 -0600

Abdul gravatar image

Hi, there.

I'm seeing some folders with names "� (invalid encoding)". They seem strange and haven't seen them lately.

I don't really understand what they are. How to fix them? I tried to remove them using the file manager, but keep showing up.

Anyone has encountered such strange file names? Would be happy if you help me out.

Lovely day.

edit retag flag offensive close merge delete

Comments

1
villykruse gravatar imagevillykruse ( 2019-01-13 07:12:10 -0600 )edit

This problem occurs after adding non english languages.

chetan gravatar imagechetan ( 2019-01-19 02:22:45 -0600 )edit

4 Answers

Sort by » oldest newest most voted
4

answered 2019-01-13 09:19:25 -0600

clnetbox gravatar image

updated 2019-01-16 03:08:11 -0600

This is a bug that should be fixed in the next version of abrt packages.
Upgrading abrt packages to version 2.11.1-2.fc29 is the root cause.

Bug : GLib-CRITICAL: g_child_watch_add_full: assertion 'pid > 0' failed
Background information and the temporary - proven to work - solution :

There's a file being located in /etc/xdg/autostart, that seems to be responsible for the problem.
This is the symbolic link file : /etc/xdg/autostart/org.freedesktop.problems.applet.desktop
The file is a symlink to /usr/share/applications/org.freedesktop.problems.applet.desktop.

Delete the weird folder either by using the command line, or in the nautilus application.
Then execute sudo rm /etc/xdg/autostart/org.freedesktop.problems.applet.desktop.
Next time after restart of the system, you won't see newly created weird folders anymore.

Update Information 2019-01-16 :

Bugfix available : abrt-2.11.1-3.fc29 has been pushed to the Fedora Updates System.
No new strange folders get created anymore - but to get rid of the journalctl message
GLib-CRITICAL: g_child_watch_add_full: assertion 'pid > 0' failed - the link file still has to
be deleted -> sudo rm /etc/xdg/autostart/org.freedesktop.problems.applet.desktop.

edit flag offensive delete link more

Comments

1

I confirm, it's related to abrt. This was the correct solution to my problem too

dave997 gravatar imagedave997 ( 2019-01-13 17:42:02 -0600 )edit

I removed the strange files using nautilus and executed the command sudo rm /etc/xdg/autostart/org.freedesktop.problems.applet.desktop. I didn't see any strange files, for now, but I'll keep an eye for the next 24hours.

I'll let you know if there are any problems, strange files/folders.

Thanks for the clarity and fix to the problem. It's really helpful.

Great day.

Abdul gravatar imageAbdul ( 2019-01-16 00:35:20 -0600 )edit
1

You're welcome @Abdul ! :)

clnetbox gravatar imageclnetbox ( 2019-01-16 04:57:41 -0600 )edit
1

answered 2019-01-13 08:09:07 -0600

updated 2019-01-13 08:12:25 -0600

This is a visible problem for non-English language settings. This is because the language and font settings are displayed in the local language when first installed.

In case of gui, you can express the folder status or other state language correctly by installing the correct language font in your country.

After installation, you can change the default language setting to English and change the folder value to English. If your local language settings are correct, this will not be a problem with your graphical (GUI) settings. It has some inconveniences in the text environment, and it has common symptoms in Linux as well.

edit flag offensive delete link more

Comments

Thanks, mate. That's really helpful.

Great day.

Abdul gravatar imageAbdul ( 2019-01-13 08:29:03 -0600 )edit
1

@Abdul Have a good time.

simmon gravatar imagesimmon ( 2019-01-13 08:39:04 -0600 )edit
1

answered 2019-01-15 04:21:03 -0600

nuvoletta8 gravatar image

Hello, thanks for your solution.

after the upgrade from fedora28 to fedora29 I found some "strange" directories inside my home. My version of abrt was already 2.11.1-2.fc29, I solved only deleting the symlink, restarting and deleting the strange directories from CLI.

edit flag offensive delete link more

Comments

You're welcome @nuvoletta8 ! :)

clnetbox gravatar imageclnetbox ( 2019-01-16 06:59:44 -0600 )edit
1

answered 2019-01-16 06:22:50 -0600

heliosstyx gravatar image

This issue is fixed today with the appropriate updates. No more strange folders.

edit flag offensive delete link more

Comments

1

Hi @heliosstyx ! Thank you for the confirmation. You can find this information in my answer above. Please note that when you want to get rid of the journalctl message, you still have to delete the symlink file. In the bug report Ernestas Kulik mentions that this part should rather get fixed in the source of the gnome-session package. But most important of course : no new "weird folders". :)

clnetbox gravatar imageclnetbox ( 2019-01-16 07:10:52 -0600 )edit

@clnetbox: Hi, thank you for your friendly comment and nice to have you in the community.

heliosstyx gravatar imageheliosstyx ( 2019-01-16 12:06:43 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-01-13 06:35:51 -0600

Seen: 1,108 times

Last updated: Jan 16