Ask Your Question
1

Fedora 28 Server install failure

asked 2019-01-16 15:04:41 -0600

updated 2019-01-22 11:46:36 -0600

My goal is to install Fedora 28.1.1, on an Intel S1200SPLR server with a Xeon E3-1275 v5 CPU, 16GB of 2133 Unbuffered ECC DDR4, Intel HD P530 integrated HD Graphics, and a 480GB SSD, all components approved by the server board manufacturer.

I am using the directly connected monitor on the VGA port; IPMI is not available to me.

First, I tested with Ubuntu 18.04.1 LTS, which installed AOK from its checksummed LiveUSB. There was no lag.

Next, I tried Fedora Server 28.1.1, from a LiveUSB generated by the Fedora LiveUSB Writer. The terminal window went blank shortly after booting from its checksummed LiveUSB with:
[ OK ] Started Show Plymouth Boot Screen.
[ OK ] reached target Paths.
[ OK ] started Forward Password Requests to Plymouth Directory Watch.

and it stalls.

I got the same result with Fedora Workstation 29.1.2. I repeated the attempts with an ISO written onto different flash drives with Rufus.

Pressing e in GRUB2 to replace quiet with nomodeset did not help. Neither did adding inst.text, vga=790, or vga=793 (ref. http://blog.fpmurphy.com/2009/09/proj...). Every time, Server 28 stalled at fb: switching to mgag200drmfb from EFI VGA.

Then, to try to get some information about what's happening, I tried Fedora Spin Workstation 29.1.2 with Cinnamon, having remembered something about GNOME problems. It installs, but Cinnamon repeatedly crashes every minute, both in LiveUSB mode and after installation and reboot. Cinnamon reports it is rendering in software mode. The 28.1.1 Xfce Spin (which uses lightdm} installs and runs OK, which does suggest something in GNOME is trouble

I opened a terminal, and copied dmesg for your review. The output of lspci-k is also linked.

I have also, as per https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/6/html/deployment_guide/blacklisting_a_module, created /etc/modprobe.d/blacklist.conf which contains one line

blacklist mgag200

and rebooted, but lspci -k still shows the Matrox in use.

Again, my objective is to install Fedora 28.1.1 Server, and the Workstation installs are just an attempt to gather information for troubleshooting.---

I also edited /etc/default/grub to remove quiet rhgb and replaced that with inst.text then ran grub2-mkconfig -o /boot/grub2/grub.cfg and rebooted. When I did, I opened up grub with e and found its next to last line read

GRUB_CMDLINE_LINUX="resume=/dev/mapper/fedora-swap rd.lvm.lv-fedora/root rd.lvm.lv=fedora/swap rhgb quiet"

I changed that to

GRUB_CMDLINE_LINUX="resume=/dev/mapper/fedora-swap rd.lvm.lv-fedora/root rd.lvm.lv=fedora/swap inst.text"

but the problem persisted.

edit retag flag offensive close merge delete

Comments

The dmesg output says the following:

 [    6.225165] mgag200 0000:01:00.0: Video card doesn't support cursors with partial transparency.
 [    6.225166] mgag200 0000:01:00.0: Not enabling hardware cursor.

Looking up "mgag200" on-line suggests that the system thinks it is using a Matrox MGA G200 video card. Can you post the results of lspci to see if the Intel integrated graphics are also available? If not, I wonder if there is way to disable the Matrox card so the system tries to use the Intel integrated graphics instead.

psg_nm gravatar imagepsg_nm ( 2019-01-16 23:12:22 -0600 )edit

lspci and /etc/modprobe.d/blacklist.conf results added to original question. The use of blacklist.conf to disable the Matrox driver does not seem to work as described in the documentation.

K7AAY gravatar imageK7AAY ( 2019-01-17 11:29:35 -0600 )edit

Poking around a little bit, I ran across the following:

They suggest trying out "mgag200.modeset=0" for the kernel parameters at boot time. Based on other articles (https://support.digium.com/s/article/How-to-disable-the-Linux-frame-buffer-if-it-s-causing-problems) I think this might be disabling the driver or the use of the Linux frame buffer. They sound similar to your situation.

psg_nm gravatar imagepsg_nm ( 2019-01-18 23:42:03 -0600 )edit

psg_nm, please turn that into an answer. That solved it!

K7AAY gravatar imageK7AAY ( 2019-01-22 18:58:47 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2019-01-23 01:01:07 -0600

psg_nm gravatar image

Considering that the system is using a Matrox MGA G200 video card (mgag200), I ran across the following articles that seem to be relevant:

They suggest adding "mgag200.modeset=0" to the boot-time kernel parameters. Based on other articles (https://support.digium.com/s/article/...) I think this might be either disabling the driver or disabling the use of the Linux frame buffer.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-01-16 15:04:41 -0600

Seen: 146 times

Last updated: Jan 23