Ask Your Question
0

There are no enabled repos

asked 2019-01-27 19:00:37 -0500

[root@fedora ~]# dnf -y install httpd
Warning: failed loading '/etc/yum.repos.d/fedora-modular.repo', skipping.
Warning: failed loading '/etc/yum.repos.d/fedora-updates-modular.repo', skipping.
Warning: failed loading '/etc/yum.repos.d/fedora-updates.repo', skipping.
Warning: failed loading '/etc/yum.repos.d/fedora.repo', skipping.
Error: There are no enabled repos.

Changing the connection destination will not solve it

edit retag flag offensive close merge delete

Comments

2

You can enable them either manually by changing enabled=0 to enabled=1 in each *.repo file or through dnf itself. Example: dnf config-manager --set-enabled fedora-updates

vmercuri gravatar imagevmercuri ( 2019-01-28 10:29:25 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2019-03-25 09:34:49 -0500

It looks like there are some issues with the repositories definition. In theory command:

dnf reinstall fedora-repos

should repair this, but since you have no repos defined... ;) I would try this way:

dnf reinstall https://ftp.icm.edu.pl/pub/Linux/fedo...

Please check if you need version 29 before installing.

ftp.icm.edu.pl is an official Fedora mirror. You may like the other source.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2019-01-27 19:00:37 -0500

Seen: 111 times

Last updated: 22 hours ago