Ask Your Question
1

Fedora 29, logout instead of screen lock

asked 2019-01-30 00:43:22 -0500

aloe1812 gravatar image

updated 2019-01-30 03:11:28 -0500

I'm using Fedora 29 with Gnome 3.30.2. When I try to lock the screen (either via shortcut or button) fedora logs my user out instead of locking the screen.

edit retag flag offensive close merge delete

Comments

I'm having exactly the same problem, does anyone have suggestions? Can you help us?

mamata gravatar imagemamata ( 2019-01-31 09:33:19 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-02-11 16:50:50 -0500

pet17 gravatar image

Yes, I can confirm that problem, too. I also noticed that going into sleep mode is not possible for me - I simply get logged out, all programs closed and data that have not been written to disk yet lost.

As a user I of course don't know how to fix it but by simply switching to display manager from the default wayland to X (gnome.org) when logging in, locking the screen works again. Since > 90% of crashes I experienced in fedora so far seem to be somehow tied to wayland that's just the first thing I try when having troubles. Hope this helps in the short run until this bug is fixed.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2019-01-30 00:43:22 -0500

Seen: 122 times

Last updated: Feb 11