Ask Your Question
2

Windows 10 not showing up in grub after installing fedora 29

asked 2019-02-05 00:28:15 -0500

mason357 gravatar image

updated 2019-02-05 16:07:25 -0500

I installed fedora 29 on my laptop that has windows 10 already. Windows 10 is not showing up on grub only fedora. Someone said try pressing c and typing exit in grub didn't work someone said type update-grub in the terminal it said command not found. I had the convertible version of the same laptop before this one it had windows 10 too and I installed fedora 27 on it the same way and windows 10 showed up in grub so I'm at a loss at what is wrong. The laptop is a thinkpad X230 from 2011.

Please explain anything I have to do in the terminal carefully because about the only things I know in the terminal is the sudo command and the yum update command. I've already setup windows how I want installed all my software and would hate to lose all my stuff with windows.. As I said the thinkpad X230T I had before this one had windows 10 and I installed fedora 27 the same way I'm doing with fedora 29 and after the install grub showed windows 10 as a boot option.

efibootmgr -v says efi variables are not supported on this system

sudo grub2-mkconfig -o /boot/grub2/grub.cfg didn't find windows

SOLVED I set the bios to UEFI only instead of legacy reinstalled fedora and can now boot to windows 10. So anyone having this problem set your bios to UEFI only not legacy then install fedora and windows should show up in grub as windows boot manager.

I guess the reason my thinkpad X230T worked in legacy was because it was windows 7 upgraded to windows 10 because in grub on that one showed as windows 7 even though it was windows 10. Windows 7 booted as legacy where a clean install of windows 10 is UEFI.

edit retag flag offensive close merge delete

Comments

Run

efibootmgr -v

find /boot/efi

And paste this information into your original question.

villykruse gravatar imagevillykruse ( 2019-02-05 11:27:48 -0500 )edit
Panther gravatar imagePanther ( 2019-02-05 13:50:01 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-02-05 03:37:32 -0500

heliosstyx gravatar image

Try this: on a BIOS machine type sudo grub2-mkconfig -o /boot/grub2/grub.cfg and on an UEFI machine type this: grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg. This will regenerate the grub-menus. I hope it will help you. Good luck.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2019-02-05 00:28:15 -0500

Seen: 337 times

Last updated: Feb 05