media sharing fedora 29

asked 2019-02-07 23:43:48 -0500

saywot gravatar image

updated 2019-02-27 20:06:57 -0500

I have about 75Gb media in /home/me/Videos and /home/me/Music. before installing Fedora 29 (from 24 to 28) I would disable SELinux and stop the inbuilt firewall ( firewalld) then enable media sharing in 'settings' . I'd then plonk my spotty botty in front of my big telly, start Kodi on a Raspberry Pi search for my Fedora PC (looking for UPnP devices) and watch my shows or listen to my tunes. Not any more. I've done everything that I usually do and there isn't a Fedora Machine to be found. I've then installed all the Rygel components and started it as a service as well as configuring Rygel to allow Videos and Music to be made available ( https://fedgeno.com/rygel-dlna-upnp-m... ) Still nothing. Now of course I could copy stuff into a USB drive and connect that to the Pi but, hell, what's the point of UPNnP media sharing if it isn't to share media over my home network. - I've checked all the setting in the chain, Kodi is OK with UPnP as is the router.

What's my next step to re-enable my DLNA/UPnP luxury ?

After 2 days of re-booting the PC (server) and the Kodi Pi (client) the client still reports "Unable to find Network Player"

Edit: I dumped Fedora as my laptop distro, installed MX Linux 18 for some long-term stability. Here's what happened ... For consistency I haven't renamed the PC on the network, the old installation was Fedora28, the new hostname is Fedora28 The laptop has a file I want to transfer into my "Videos" directory which allows everybody read/write access The file browser in MXLinux sees the directory but when I try to open it I see a pop-up with " Invalid URI ‘http://[[fd2c:5cfb:773e:0:da4c:eee0:b05a:e000]]"

I don't think that this message is some vestigial location from the old PC

Anyway, let me know your thoughts

edit retag flag offensive close merge delete

Comments

so this is unaswerable ?

saywot gravatar imagesaywot ( 2019-02-11 05:35:54 -0500 )edit

I just thought I'd check from time-to-time to see if there's an answer still nothing suggested

saywot gravatar imagesaywot ( 2019-02-27 19:56:10 -0500 )edit

http://[[fd2c:5cfb:773e:0:da4c:eee0:b05a:e000]]

Yeap.. no [] and only one : allowed in URLs

you can: use samba to mount your server, or you can use sshfs:

sshfs user@server:/home/user/ mountpoint

Easy, is encrypted, works. If you use keys to auth against sshd, you can have them supplied by gnome-keyring-daemon and need not to enter a password.

And for your kodi problems: "netstat -lnap| grep LISTEN" Kodi uses Ports 1146,1185,1258,8080 and a service port with variable number you can't access from a remote client anyway.

if they are not present after starting kodi => cause found

rdtcustomercare gravatar imagerdtcustomercare ( 2019-02-28 10:30:23 -0500 )edit

if you can't connect from remote to the ports named, your firewall is still up and messed up too, as the firewall daemon would punch a hole clear for kodi on startup. btw.. no need to disable SEL too, kodi works fine with enabled SEL.

rdtcustomercare gravatar imagerdtcustomercare ( 2019-02-28 10:32:11 -0500 )edit