Ask Your Question
0

Desperate help required for grub and splash screen - Fedora 29

asked 2019-02-09 09:24:43 -0500

c2yCharlie gravatar image

Hello everyone,

I have been using Linux distributions for quite sometime now (Ubuntu 18.04 earlier and Fedora 29 now). Their are two major issues which I am facing with Fedora 29 and no matter what I try, it just doesn't solve.

The issue is that after I installed the proprietary Nvidia drivers for my GPU using this method, the splash screen automatically changed to text plymouth (grey screen with 3 white dots). I tried to change it to "charge". I followed method1 and method2. I also tried certain other methods but they were all very similar to the above two methods. However, it didn't change a thing. I also noticed that my GRUB resolution just wouldn't change, no matter the code in the grub file. It was stuck at a default resolution which I could not get to change. The configuration of the GRUB file is this:

 GRUB_TIMEOUT="10"
 GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
 GRUB_DEFAULT="saved"
 GRUB_DISABLE_SUBMENU="true"
 GRUB_VIDEO_BACKEND="efi_gop"
 #GRUB_TERMINAL_OUTPUT="gfxterm"
 GRUB_CMDLINE_LINUX="rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 resume=/dev/mapper/fedora-swap rd.lvm.lv=fedora/root rd.lvm.lv=fedora/swap rhgb quiet splash"
 GRUB_DISABLE_RECOVERY="true"
 GRUB_FONT_PATH="/boot/efi/EFI/fedora/fonts/LiberationMono-Regular.pf2"
 GRUB_GFXMODE="1920x1080"
 GRUB_GFXPAYLOAD_LINUX=keep
 export GRUB_COLOR_NORMAL="light-gray/black"
 export GRUB_COLOR_HIGHLIGHT="magenta/black"

I then decided to check the supported resolutions using the terminal at grub but to my surprise, I kept getting the message "Can't find command" for vbeinfo and videoinfo which is really strange. I would like to notify that even when I was using Ubuntu, no matter what I tried, it just wouldn't accept my native resolution in the grub menu which wasn't the case earlier, i.e the grub resolution was at native resolution but then after some days and I don't know exactly when, grub stopped supporting my native resolution. However, do note that videoinfo used to work then and showed the highest supported resolution as 1280x1024 (I don't know why because earlier it was running fine at 1920x1080).

I have been trying to look for any possible help to rectify these issues but none have worked. It is really frustrating to not be able to rectify these petty issues. The issues are summarized as follows:

  1. Cannot seem to find a way to change splash screen to default plymouth theme after Nvidia drivers installation.
  2. GRUB resolution won't change no matter what I write in the config file.
  3. GRUB menu terminal says, "Can't find command" for the following syntax - vbeinfo, videoinfo during boot up.

Note: Secure boot is disabled and I have a dual boot system (Windows 10 and Fedora 29) both installed as UEFI platforms.

I am very desperate to solve this problem as it is driving me crazy and would really really appreciate any help regarding this issue.

Thanking in advance.

edit retag flag offensive close merge delete

Comments

See https://www.if-not-true-then-false.co... . Use dnf to find vbeinfo , dnf provides .....

Panther gravatar imagePanther ( 2019-02-09 13:02:08 -0500 )edit

The command may have changed to videoinfo

Panther gravatar imagePanther ( 2019-02-09 13:07:47 -0500 )edit

1280x1024 is for old 5:4 screen format like old TVs for wide screen 16:9 1280x720 or 1920x1080 would be better. See this wikipedia entry.

I am afraid I have no solution for you. This issue seems to be relates to the flicker free boot project. What seems to happen is that the UEFI video driver is used for a bit longer by the kernel than it used to be, and this seems to cause the behaviour you see.

villykruse gravatar imagevillykruse ( 2019-02-09 13:14:04 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2019-02-09 15:25:44 -0500

GRUB_GFXMODE="1920x1080"

is not a vbe mode .. but it needs to be one, if you use vbe.

to use vbe, you have to tell it grub:

GRUB_VIDEO_BACKEND=vbe

this is vbe :

GRUB_GFXMODE=0x11b

if you don't wanne use vbe, don't forget to add the color depth.

GRUB_GFXMODE="1440x900x32"

-> I <- would prefer vbe, but thats your problem. GRUB does not know about NVIDIA, so the installation of NVIDIA just set some wrong parameters in your /etc/default/grub

If you make changes to /etc/default/grub, you need to make a new gub.conf and new Initramfses . Otherwise, you will never see a change, because the necessary drivers a put into the initramfs.

If you want to make a new config, here is how :

EFI: grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg BIOS: grub2-mkconfig -o /boot/grub2/grub.cfg

you wanne change your plymouth boot animation?

dnf install plymouth-theme-spin* plymouth-set-default-theme spinfinity

you want to update your initramfs ? use this:

dracut -f

done.

You wanne read more : https://marius.bloggt-in-braunschweig...

You may need http://deepl.com to translate it to english. It's really time for fedora guys to learn german, that blog is soooooo good in solving fedora related (and other people) problems..

now reboot and tell us what happend.

edit flag offensive delete link more

Comments

Hey, thanks for the response mate. I am sorry for the late reply as I was away. I have tried the methods listed by you but it doesn't seem to work. What is troubling me the most is why isn't my grub executing commands like videoinfo or vbeinfo. Whenever I run them I get the error "Can't find command". Do you have any idea why this is happening and any possible fix?

c2yCharlie gravatar imagec2yCharlie ( 2019-02-15 08:05:10 -0500 )edit

your systems root inside grub could be unset. Before cmds in grubshell work,you have to point a device as root. Sometimes, this does not work by default. if that is the case with your grub, you need one with extended grubknowlage infront of your pc. Thats because it's highly dynamic and we would sit here for weeks if we two would try to solve this ;)

If you have a local LUG, that would be a good starting point.

What you can try first: Bootmenu -> 'C' -> double TAB -> results in cmd list. if not there, update grub and reinstall grub to disk.

rdtcustomercare gravatar imagerdtcustomercare ( 2019-02-24 10:32:30 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-02-09 09:24:43 -0500

Seen: 317 times

Last updated: Feb 09