Trouble Compiling ZSNES From Source / Using SDL

asked 2019-02-17 13:52:11 -0500

updated 2019-02-24 14:44:37 -0500

Hello,

This is a question with several parts. I am not completely unfamiliar with Fedora and Linux in general, but I am very unfamiliar with compiling third-party software from source. I have been able to do it a few times. Still, I could use some advice because the third-party documentation not address the problem I've encountered. I've included the terminal output below.

Questions:

  1. When I see "SDL >= 1.2.0" this refers to the SDL software of a version equal to or less than 1.2.0 - right?

  2. The version of SDL I have is the x86_64 arch version of 1.2.15. The software won't install without it, I assume. Is there anything else I can do?

  3. Am I missing anything that would make the compiling successful?

  4. Is this software or anything similar to it available in .rpm form?

[usernameredacted@computerycomputerface src]$ sudo sh ./autogen.sh && gmake && gmake install
[sudo] password for usernameredacted: 
Generating build information using aclocal and autoconf...
./autogen.sh: line 6: sdl-config: command not found
aclocal: error: unrecognized option '--acdir=/share/aclocal'.
aclocal: Try '/usr/bin/aclocal --help' for more information.
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for g++... no
checking for c++... no
checking for gpp... no
checking for aCC... no
checking for CC... no
checking for cxx... no
checking for cc++... no
checking for cl.exe... no
checking for FCC... no
checking for KCC... no
checking for RCC... no
checking for xlC_r... no
checking for xlC... no
checking whether we are using the GNU C++ compiler... no
checking whether g++ accepts -g... no
checking for nasm... nasm
./configure: line 3574: syntax error near unexpected token `1.2.0,,AC_MSG_ERROR'
./configure: line 3574: `AM_PATH_SDL(1.2.0,,AC_MSG_ERROR(SDL >= 1.2.0 is required))'
gmake: *** No targets specified and no makefile found.  Stop.

Update: Followed advice from SteveEbey73701. Here's the terminal output. I don't understand what is wrong now.

[usernameredacted@computerycomputerface src]$ sh ./autogen.sh && gmake
Generating build information using aclocal and autoconf...
./autogen.sh: line 6: sdl-config: command not found
aclocal: error: unrecognized option '--acdir=/share/aclocal'.
aclocal: Try '/usr/bin/aclocal --help' for more information.
configure.in:49: error: possibly undefined macro: AC_MSG_ERROR
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
configure.in:101: error: possibly undefined macro: AM_PATH_SDL
configure.in:104: error: possibly undefined macro: AM_PATH_ZLIB
configure.in:109: error: possibly undefined macro: AM_PATH_LIBPNG
configure.in:228: error: possibly undefined macro ...
(more)
edit retag flag offensive close merge delete

Comments

I would not use sudo for the first part of the compile. Try sh ./autogen.sh && gmake then use sudo gmake install, so that only the install runs as root, and not the entire compile process running as root. Compiling code as root could lead to problems.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2019-02-17 20:57:56 -0500 )edit

you might be missing the devel files for SDL try running sudo dnf install SDL* and see what happens. be sure the SDL is all uppercase. and run make after configure, then if it is successful, run sudo make install.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2019-02-24 21:43:47 -0500 )edit