Ask Your Question
1

Disable GDM at system start

asked 2019-03-18 17:34:59 -0500

roypen gravatar image

Hello,

My Fedora 29 freezes when loading Gnome. It happens every time afrer "starting Gnome display..." info. I can't switch to another tty. The whole system hangs. Switching to previous kernels doesn't help.

Is there any way to disable GDM at system start? I've managed to run Fedora Live with rescue command so i have access to my files but... i can't figure out how to disable GDM from loading at startup. Please help.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
3

answered 2019-03-19 01:50:01 -0500

villykruse gravatar image

There is a way, but it depends on what you want to do instead.

At the grub selection, hit e and then move the cursor down to the line starting with linux. At the end of that line append the nunber 3, and hist x to continue booting.

When the system comes up you will get a login prompt; log in and the run the command

 systemctl set-default multi-user.target

After that you won't start gdm (or any other display manager) when booting.

edit flag offensive delete link more

Comments

I started fedora with runlevel 3 and than reinstalled all gnome desktop environment. Now the system is on line :). Thanks for your help.

roypen gravatar imageroypen ( 2019-03-19 11:03:39 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-03-18 17:34:59 -0500

Seen: 75 times

Last updated: Mar 19