Ask Your Question
1

Doing ssh to an server, doesn't change Gnome Terminal title

asked 2019-03-21 08:41:46 -0500

andrea76 gravatar image

Hi, I remember that once a time I ssh'd to a server, the Gnome Terminal title changes to username@server-hostname

but this now doesn't happen anymore. How can I fix this?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2019-03-21 09:10:03 -0500

Night Romantic gravatar image

Andrea, it does happen for me. Can this be some transient problem?

Also please check Gnome Terminal Settings -> Profiles -> Default Profile or your current one if you have several -> Commands tab (between "Scrolling" and "Compatibility") -> setting "When terminal commands set their own titles".

Mine is set to "Change initial title" -- and it works exactly as you want it to. Check your setting.

P.S. Settings' names can be a bit different as I translate from my native language, but I hope you can figure them out. Please tell me if you can't.

edit flag offensive delete link more

Comments

Unfortunately, mine is set to "Change initial title", but it still doesn't work.

andrea76 gravatar imageandrea76 ( 2019-04-08 06:14:51 -0500 )edit
  • Do other commands (other than ssh) set their titles? mc (Midnight Commander) does that for me.

If mc doesn't also, then it's likely gnome-terminal's settings. If ssh doen't, but mc does -- then maybe it's something with ssh specifically.

You can try to make new profile in gnome-terminal (and maybe make a new one the default), you can try other variants for "When terminal commands set their own titles" setting, see if any of them works.

Other than that, I'm out of ideas.

Night Romantic gravatar imageNight Romantic ( 2019-04-09 03:06:17 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2019-03-21 08:41:46 -0500

Seen: 42 times

Last updated: Mar 21