Ask Your Question
0

Can't ping/connect to router, also I can't visit some websites!

asked 2019-04-13 11:51:11 -0500

Alan0xb gravatar image

I've installed Fedora Xfce 29 on my Laptop, and everything workt fine. I upgraded and updated all and installed some things above the Terminal with dnf. I wanted to download something with my default webbrowser Chromium, but it showed me just Google, Facebook or Reddit and other known websites. DuckDuckGo or an androidstudio.com for example can't be resolved. I checked the enp4s0 and set it up with dhcpcd, then I checked the file /etc/resolv.conf, it was quite empty, just a IPv6 as nameserver. I added the Google DNS 8.8.8.8 and 8.8.4.4. After this no results! I checked the ping to my Router and the says me the Destination Host is Unreachble, the same with the 8.8.4.4 address. I checked the IP address on enp4s0, and it shows me a totally different IP address as my Router's DHCP Server says I shuld have (Example: 192.168.34.45 and the IP address of my device is 165.234.0.22) I need help, I searched for solutions the whole day with no results.

edit retag flag offensive close merge delete

Comments

The 192.168.34.45 address is an internal web address that can be used to communicate with other devices on the same LAN (local area network) . The 165.234.0.22 address I suspect is an address assigned by your internet provider that your router shares with all the devices on your network. The DNS 8.8.8.8 and 8.8.4.4 are ipv4 servers. There are many things that could be going wrong. Can you ping to some known numeric ip addresses? What does the ifconfig command return from a terminal window?

nmgiffin gravatar imagenmgiffin ( 2019-04-13 13:54:17 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
1

answered 2019-04-13 16:44:22 -0500

Alan0xb gravatar image

Thanks for you're help but I got an solution now! ;) I disabled the firewalld, disconnected my network. Then I deleted all the old network configurations. I reconnect via LAN and updated the system, after this everything worked fine. I literally don't know what was wrong but I think my router was too dumb to configure my system. Thanks for you're help.

edit flag offensive delete link more
0

answered 2019-04-15 04:03:33 -0500

claramae gravatar image

Thanks disabling firewalld works for me too.

edit flag offensive delete link more
0

answered 2019-04-13 14:11:17 -0500

Kostya Vasilyev gravatar image

Given the 192.168.34.45 it sounds like your network interface isn't getting assigned an address over DHCP.

XFCE should be showing an applet in the panel (in the corner of your screen) to bring up network manager.

I'd use that (right click, edit connections) to check that your ethernet connection is configured there, with an automatic address under ipv4... and then "sudo restart NetworkManager".

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2019-04-13 11:51:11 -0500

Seen: 46 times

Last updated: Apr 13