Ask Your Question
1

How to fix missing icons in program menus and context menus?

asked 2013-02-22 12:29:16 -0500

Bucic gravatar image

updated 2013-12-08 10:38:52 -0500

Inkscape, GIMP, LibreOffice and probably many other programs have missing icons in menus. While for some programs it's a culprit, for LibreOffice (OpenOffice) it's a major problem since its UI is ancient and hard to navigate even with the icons.

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
2

answered 2013-12-18 03:10:11 -0500

Ahmad Samir gravatar image

updated 2014-02-05 07:07:49 -0500

(I've already posted in http://forums.fedoraforum.org/showthread.php?p=1680581#post1680581 , re-posting here for users not subscribed there):

Both gtk-menu-image and gtk-button-images were deprecated and ignored, after that they made them deprecated but not ignored: https://git.gnome.org/browse/gtk+/commit/?id=627a03683f5f41efbfc86cc0f10e1b7c11e9bb25 https://git.gnome.org/browse/gtk+/commit/?id=c46aca463a9d66cf402ec8c3f9f2e2efc98c42ca

the problem is the gsettings keys (org.gnome.desktop.interface buttons-have-icons and menus-have-icons) are gone so I don't see a way to set them...

However it seems you can set the relevant GtkSettings via the gnome-settings-daemon xsettings plguin: open dconf-editor -> org.gnome.settings-daemon.plugins.xsettings and change the overrides key from:

{}

to:

{'Gtk/ButtonImages': <1>, 'Gtk/MenuImages': <1>}

usually the change is instantaneous (e.g. in gimp), but some apps need to be restarted (e.g. firefox).

Or just use gsettings:

gsettings set org.gnome.settings-daemon.plugins.xsettings overrides "{'Gtk/ButtonImages': <1>, 'Gtk/MenuImages': <1>}"

but note that this method overwrites the current value of that key; one obvious caveat is if you've previously enabled pasting with the middle click from gnome-tweak-tool -> "keyboard and mouse", you'll need to re-set it there again (unlike the above gsettings command, gnome-tweak-tool "adds" new values to the overrides key and doesn't blindly overwrite it).

Edit: testing recently, it seems now that toggling either of these settings in gnome-tweak-tool remove the custom values added above:

  • Top Bar -> "show application menu"
  • Keyboard and mouse -> middle-click paste so if you toggle any of those settings you'll have to re-add the 'Gtk/ButtonImages': <1>, 'Gtk/MenuImages': <1> bits.
edit flag offensive delete link more

Comments

This is the correct answer starting with F20/gnome 3.10.

mlipp gravatar imagemlipp ( 2014-02-04 02:20:44 -0500 )edit
mlipp gravatar imagemlipp ( 2014-02-04 08:46:34 -0500 )edit

i use F25, i tried but doesn't seem to work

adorzhang gravatar imageadorzhang ( 2017-02-03 07:41:10 -0500 )edit
1

answered 2013-02-22 12:45:56 -0500

Bucic gravatar image

updated 2013-12-08 10:37:53 -0500

  1. Install Gnome Tweak Tool

    su -c 'yum install gnome-tweak-tool'

  2. Enable: Theme > Menus Have Icons

EDIT:
It seems the tool doesn't have "Themes' section anymore. In this case use gconf-editor as described here
http://askubuntu.com/questions/85183/why-do-my-menus-have-little-icons-next-to-the-items

edit flag offensive delete link more

Comments

This solution doesn't seem to work on Fedora 20. Any thoughts?

Bucic gravatar imageBucic ( 2013-12-10 12:11:55 -0500 )edit

See the answer below. Things changed with gnome 3.10.

mlipp gravatar imagemlipp ( 2014-02-04 02:20:05 -0500 )edit
0

answered 2017-02-11 08:41:01 -0500

Logout , then login screen switch GNOME-xorg. ( F25)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-02-22 12:29:16 -0500

Seen: 18,492 times

Last updated: Feb 11 '17