English
Ask Your Question
0

Mouse and keyboard not working after upgrade to F18 from F17

asked 2013-03-05 07:30:19 +0000

srinath gravatar image

Recently, I upgraded my laptop from Fedora 17 to Fedora 18 using the FedUp tool.

After the upgrade, the machine booted up and shows the login screen. On the screen, I'm unable to use the keyboard or the mouse pointing device. They don't work. Tried connecting another (external) keyboard and mouse pointing device via USB port. They don't work as well. I booted the machine into Windows - mouse and keyboard work fine there. Also booted the machine using the Live Fedora media - the mouse and keyboard work fine there too.

Can you help me resolve this issue?

The laptop is a dual boot machine (Windows + Fedora Linux)

edit retag flag offensive close delete

Comments

Can you access a virtual terminal, ie, does pressing "ctrl alt f2" work? If not, we'll try booting into console mode and collecting some logs.

FranciscoD_ ( 2013-03-05 08:42:39 +0000 )edit

Hi FranciscoD_, Thanks for the reply. You mean Ctrl+Alt+F2 on the login screen. If so, that did not work.

srinath ( 2013-03-05 09:09:53 +0000 )edit

Hi @srinath: Please try booting in run level 3 as instructed here and see if your mouse/keyboard works? If it does, please try running the steps given here to clean up your system after the upgrade and see if that helps. If you do manage to login, also look at the logs: dmesg, /var/log/messages, /var/log/Xorg.0.log for anything suspicious.

FranciscoD_ ( 2013-03-05 23:17:42 +0000 )edit

Hi @FranciscoD_, I was performing the upgrade cleanup tasks. After relabelling (step 4), the machine rebooted and booted into normal mode (level 5) and the mouse and keyboard worked well. Should I continue with the rest of the steps?

srinath ( 2013-03-06 10:40:31 +0000 )edit

I suggest you complete all the steps. There may be other issues that crop up later :)

If relabelling fixed it, it was probably an selinux issue.

Please mark the answer I've given below as correct @srinath. It will help others. Thanks :)

FranciscoD_ ( 2013-03-19 02:51:55 +0000 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-03-19 02:53:32 +0000

Booting into runlevel 3 and cleaning up the system after the upgrade seems to have fixed the issue for the reporter.

edit flag offensive delete publish link more

Your answer

Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

Add answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers to your questions.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question tools

Follow
2 followers

Stats

Asked: 2013-03-05 07:30:19 +0000

Seen: 2,490 times

Last updated: Mar 19 '13