English
Ask Your Question
0

httpd service won't start post fedora 18 upgrade

asked 2013-03-17 10:54:41 +0000

diljeet gravatar image

updated 2013-08-01 12:57:51 +0000

hi there

Post upgrade to Fedora 18 httpd service refuses to start. Below given is the command used to start the service and the error I'm getting.

$ service httpd start

Job for httpd.service failed. See 'systemctl status httpd.service' and 'journalctl -xn' for details.

I' ve also tried the suggestions given in the error message. Posted below is the response.

$ systemctl status httpd.service
httpd.service - The Apache HTTP Server
      Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled)
      Active: failed (Result: exit-code) since Sun 2013-03-17 15:18:45 IST; 45min ago
     Process: 2515 ExecStop=/usr/sbin/httpd $OPTIONS -k graceful-stop (code=exited, status=1/FAILURE)
     Process: 2513 ExecStart=/usr/sbin/httpd $OPTIONS -DFOREGROUND (code=exited, status=1/FAILURE)
Mar 17 15:18:45 fedora-diljeet httpd[2513]: httpd: Syntax error on line 152 of /etc/httpd/conf/httpd.conf: Cannot load modules/mod_authn_al...irectory
Mar 17 15:18:45 fedora-diljeet systemd[1]: httpd.service: main process exited, code=exited, status=1/FAILURE
Mar 17 15:18:45 fedora-diljeet httpd[2515]: httpd: Syntax error on line 152 of /etc/httpd/conf/httpd.conf: Cannot load modules/mod_authn_al...irectory
Mar 17 15:18:45 fedora-diljeet systemd[1]: httpd.service: control process exited, code=exited status=1
Mar 17 15:18:45 fedora-diljeet systemd[1]: Failed to start The Apache HTTP Server.
Mar 17 15:18:45 fedora-diljeet systemd[1]: Unit httpd.service entered failed state



$ journalctl -xn

Mar 17 15:47:16 fedora-diljeet gdm-password][2758]: gkr-pam: unlocked login keyring
Mar 17 15:47:16 fedora-diljeet dbus-daemon[1436]: dbus[1436]: [system] Rejected send message, 2 matched rules; type="method_return", sender=":1.0" (ui
Mar 17 15:47:16 fedora-diljeet dbus[1436]: [system] Rejected send message, 2 matched rules; type="method_return", sender=":1.0" (uid=0 pid=1397 comm="
Mar 17 15:47:16 fedora-diljeet gdm-simple-slave[1500]: WARNING: GdmSlave: could not fetch type of session '1': No such file or directory
Mar 17 15:47:17 fedora-diljeet dbus-daemon[1436]: ** Message: No devices in use, exit
Mar 17 16:01:01 fedora-diljeet CROND[2815]: (root) CMD (run-parts /etc/cron.hourly)
Mar 17 16:01:01 fedora-diljeet run-parts(/etc/cron.hourly)[2818]: starting 0anacron
Mar 17 16:01:01 fedora-diljeet run-parts(/etc/cron.hourly)[2824]: finished 0anacron
Mar 17 16:01:01 fedora-diljeet run-parts(/etc/cron.hourly)[2826]: starting mcelog.cron
Mar 17 16:01:01 fedora-diljeet run-parts(/etc/cron.hourly)[2830]: finished mcelog.cron

Any help would be highly appreciated.

Regards

Diljeet

edit retag flag offensive close merge delete

Comments

I Have the same error.

You have:

> Syntax error on line 152 of > /etc/httpd/conf/httpd.conf

And I have:

> Syntax error on line 353 of > /etc/httpd/conf/httpd.conf

I Have remove (comented) the 353 line of /etc/httpd/conf/httpd.conf

> # Supplemental configuration

> # Load config files in the "/etc/httpd/conf.d" directory, if any.

> IncludeOptional conf.d/*.conf

I have comented the last line. So I have missed the aditional configuration.

If you find a best solution, please send it. Thanks.

AntonioSPR ( 2013-03-21 19:45:37 +0000 )edit

I have the same problem with a fresh fedora 19

Ruggero Turra ( 2013-07-08 10:55:56 +0000 )edit

I'm getting the same error on a fresh Fedora 19.

Randell ( 2013-08-01 06:03:23 +0000 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2013-03-24 07:31:51 +0000

diljeet gravatar image

Ok Guys,

Issue has been resolved. All I did was create a new httpd.conf file from httpd.conf.rpmnew file. Just had to comment the deprecated modules which are no longer used in Fedora 18 and call the optional include files shipped with fedora 18.

edit flag offensive delete link more

Comments

You can use the rpmconf tool to do this more easily. Please install it and check the man page

FranciscoD_ ( 2013-07-08 11:27:37 +0000 )edit
0

answered 2013-03-17 11:12:41 +0000

I'd suggest you first clean up your system if you haven't yet. That should probably fix it.

The error seems to be something in the httpd.conf file as it says above. If you've made modifications to it, you might want to recheck them. Other wise, it could be remenants from the previous fedora version that the clean up should fix.

edit flag offensive delete link more

Comments

Appreciate your suggestion. I, ve used fedup tool to upgrade to fedora 18. And I believe post the installation of new packages previous packages get removed automatically.

diljeet ( 2013-03-17 15:39:27 +0000 )edit

Yes, but configuration files do not. As package maintainers, we do not overwrite or remove configuration files during an update, since we don't want users to have to configure their tools after every update. Please just run the clean up. It will fix the issue.

FranciscoD_ ( 2013-03-21 22:06:44 +0000 )edit

Link to http://fedorasolved.org/Members/fenris02/post_upgrade_cleanup is dead.

Randell ( 2013-08-01 06:05:56 +0000 )edit

The site could've been down for maintenance. It's back up now.

FranciscoD_ ( 2013-08-01 12:57:13 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Stats

Asked: 2013-03-17 10:54:41 +0000

Seen: 8,929 times

Last updated: Aug 01 '13