English
Ask Your Question
0

CPU performance slow while on battery in Fedora 18

asked 2013-03-27 14:47:35 +0000

cshelton gravatar image

updated 2013-04-02 23:06:22 +0000

I updated from Fedora 17 to Fedora 18 a few days ago using fedup. The transition seemed to go fine and after a few "yum updates" all is well, except...

If my laptop is not plugged into the wall, the CPU performance is much worse. I use my laptop for compilation and running CPU intensive programs while travelling. Under Fedora 17, the performance was pretty much the same with our without wall power.

I read the Fedora 18 Power Management Guide (which seems to be a bit out-of-date in that I have no /etc/tuned-profile despite having the necessary packaged installed). I changed the active profile to balanced and also tried throughput-performance. Eventually, I turned it off. None of these things seem to have an effect.

I can run a CPU-intensive job. It will speed up and slow down as I plug in and unplug the power adaptor. I know under Fedora 17 this didn't happen (or if it did, it was a much much less noticable effect).

Is there another setting I should be looking at?

UPDATE: I tried the governor as suggested below and even turned it off. That didn't seem to change anything (it was on regardless of the power state). As noted, cpupower told me that the frequency was limited to between 800-1000MHz (although it knew the processors could go to 2.4GHz), so I changed that. It now will hit 2.4 GHz on some compute jobs. However, it still feels slower (but I have no quantifiable data).

Additionally, it seems to take more power during sleep (I think even before I made these changes). Again, I don't have hard data. If anyone has other experiences, I'd like to hear them. The laptop is a Thinkpad W520.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2013-03-28 16:54:22 +0000

You should install powertop to make sure that fedora isn't automatically changing the cpu governer when unplugging your laptop. I believe powertop allows you to turn off the cpu governer.

edit flag offensive delete link more

Comments

Thanks. I could see that the governor was active with powertop, but pressing enter to toggle it didn't help. I searched for information about the governor and installed cpupower which tells me that the current policy is to keep the frequency within 800 and 1000 MHz (although it acknowledges that the hardware limits goes to 2.4 GHz). But, I cannot find where this policy is being set. Using tuned-adm to change the profile or turn it off doesn't change this reported limit. (And indeed, I don't see the freq going above 1000 MHz ever). Any ideas how I might change this? Thanks!

cshelton ( 2013-03-30 14:17:50 +0000 )edit

Just as one more comment, I tried using "sudo cpupower frequency-set --governor cpufreq_ondemand" and it cam back with an error and listed "common errors" I'm taking this from section 3.2.1 of the Fedora user guide, but it looks like that's either out-of-date or there is something else preventing me from setting the governor.

cshelton ( 2013-03-30 14:38:21 +0000 )edit

If you are using gnome shell install the cpu freq extension from here "https://extensions.gnome.org/extension/444/cpu-freq/" and also do 'yum install gnome-applets and yum install cpufreq-utils.

shaggy814 ( 2013-03-31 02:27:22 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2013-03-27 14:47:35 +0000

Seen: 997 times

Last updated: Apr 02 '13