Ask Your Question
4

How I disable yum presto deltarpms on Fedora 19

asked 2013-04-11 20:54:34 -0500

sergiomb gravatar image

On Fedora 19 yum presto is not anymore one plugin , I can't disable it , I try presto=0 in /etc/yum.conf but doesn't work

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
7

answered 2013-04-12 13:34:26 -0500

mether gravatar image

Yum Presto plugin functionality has been merged into yum directly in Fedora 19+. To disable Delta RPMS, you need to set deltarpm=0 in /etc/yum.conf

edit flag offensive delete link more

Comments

this option worked , thanks

sergiomb gravatar imagesergiomb ( 2013-04-15 19:57:01 -0500 )edit
0

answered 2013-07-28 15:27:54 -0500

murple gravatar image

Presto/deltarpms may be great if you're still using dialup or something, but personally I find it an obnoxious slowdown. It's way faster to download the whole RPM than to sit and wait as my computer churns to build a delta RPM that saves maybe 10 seconds of download time. The presto.conf file no longer exists in Fedora 19, so I hope there's some other way to turn this crap off.

edit flag offensive delete link more

Comments

you need to set deltarpm=0 in /etc/yum.conf

sergiomb gravatar imagesergiomb ( 2013-07-29 16:00:12 -0500 )edit
0

answered 2013-09-23 12:41:24 -0500

scrutari gravatar image

updated 2013-09-23 12:42:58 -0500

Set deltarpm=0 in /etc/yum.conf. Refer to man yum.conf for more details.

edit flag offensive delete link more
0

answered 2013-04-11 22:20:31 -0500

skytux gravatar image

Take a look at this thread:

http://lists.fedoraproject.org/pipermail/users/2013-April/434095.html

Basically, you have to create this file:

$ cat /etc/yum/pluginconf.d/presto.conf 
[main]
enabled=0

But why would you disable presto? Do you know what is it for?

edit flag offensive delete link more

Comments

is for deltarpms isn't it ? I think I loose more time on decompression on disk , that download it , and I have a great bandwidth without limit . Thanks I will test in next update

sergiomb gravatar imagesergiomb ( 2013-04-11 22:34:45 -0500 )edit

Ok, good luck! :)

skytux gravatar imageskytux ( 2013-04-12 09:34:49 -0500 )edit

sorry doesn't worked

sergiomb gravatar imagesergiomb ( 2013-04-15 19:47:41 -0500 )edit

In that thread people said it worked!

skytux gravatar imageskytux ( 2013-04-15 21:38:37 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-04-11 20:54:34 -0500

Seen: 8,839 times

Last updated: Sep 23 '13