English
Ask Your Question
0

How do I run httpd-2.2 on Fedora 18?

asked 2013-06-14 02:22:30 +0000

wraeth gravatar image

updated 2014-09-28 23:22:59 +0000

mether gravatar image

Greetings;

I have recently updated my work machine to use Fedora 18, which seems to only provide httpd-2.4*. As this is my work machine, I have some software that I would prefer to get working, however some of its components rely on httpd-2.2 - specifically related around symbol naming that has changed between the two versions.

I've already tried downloading the RPM from F17 (httpd-2.2.23-1.fc17.x86_64.rpm), however there are dependency issues:

    --> Finished Dependency Resolution
Error: Package: httpd-2.2.23-1.fc17.x86_64 (/httpd-2.2.23-1.fc17.x86_64)
           Requires: libpcre.so.0()(64bit)
Error: Package: httpd-2.2.23-1.fc17.x86_64 (/httpd-2.2.23-1.fc17.x86_64)
           Requires: httpd-tools = 2.2.23-1.fc17
           Available: httpd-tools-2.4.3-12.fc18.x86_64 (fedora)
               httpd-tools = 2.4.3-12.fc18
           Available: httpd-tools-2.4.4-3.fc18.x86_64 (updates)
               httpd-tools = 2.4.4-3.fc18
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I can get the RPM for httpd-tools, however PCRE presents something of an issue... Can anyone suggest how I might get httpd-2.2 installed on my system?

Thanks in advance.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
2

answered 2013-06-14 04:19:29 +0000

Unfortunately, you can't just download Fedora X's rpms and expect them to work on Fedora Y. There is no easy way of running an outdated version of software on a new Fedora release. You'll have to grab the srpm, rebuild it for your Fedora release, figure out conflicts, install it and hope that it works.

In this specific case, you need to also download the httpd-tools, even the pcre package from F17 (and other dependencies that may crop up too!). This may or may not work really.

Is it not possible to request upstream to update their software to work with the new httpd, as opposed to working with an older one, which I'd expect to have unfixed bugs?

edit flag offensive delete link more

Comments

1

I thought that might be the case, but was hoping that there might be an easier workaround. Unfortunately, upstream is IBM, so while update requests have been and will be made, it's not going to happen overnight...

wraeth ( 2013-06-14 05:10:41 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Stats

Asked: 2013-06-14 02:22:30 +0000

Seen: 553 times

Last updated: Jun 14 '13