English
Ask Your Question
0

Superuser root password not working

asked 2013-06-23 16:59:03 +0000

Learner gravatar image

Guys, I have Fedora 17 and Windows 8 installed. I want to make windows 8 as default os while startup. for this i type in terminal su - "my pw" gedit /etc/default/grub it asks fo my pw again but when i type, nothing appears on screen and when i hit enter, different responses come, majorly invalid password. How do i fix this?

edit retag flag offensive close delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2013-06-23 18:26:09 +0000

sideburns gravatar image

Well, no wonder: the command you're using is wrong. Try this instead:

su -c 'gedit /etc/default/grub'

And enter the root password when prompted. (As always, the password won't echo, not even stars.) Using the -c tells bash to give you root access only for the one command, rather like sudo.

edit flag offensive delete publish link more

Comments

sudo works! Thanks for that! But now when i save after editing the grub file, it gets saved but terminal says that the action has failed because no such directory exists. And the changes are not executed! Any solution?

Learner ( 2013-06-24 18:47:53 +0000 )edit

Your answer

Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

Add answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers to your questions.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Stats

Asked: 2013-06-23 16:59:03 +0000

Seen: 164 times

Last updated: Jun 23 '13