Ask Your Question
0

"Checking for Updates" never completes on Gnome 64-bit

asked 2013-06-25 13:40:18 -0500

baroquequest gravatar image

updated 2013-06-26 07:06:52 -0500

FranciscoD_ gravatar image

I have installed Fedora 18 Gnome 64-bit before, so I am familiar with the many questions asked. I have installed it on SSDs and SATA hard drives. Today I tried to install it on a WDC PATA drive which has a Vantec model CB-IS100 adapter so it can communicate with SATA controllers. Everything else is the same as I used before, i.e. Intel DH67BL motherboard and i5-2405S CPU. Fedora recognized the hard drive's model number and size. The "Network" dialog shows that I have a Wired connection at 100 Mb/s and Firefox is able to view the Internet. The "Disks" dialog does not show any errors.

However, now that Fedora has been completely installed, it never completes "Checking for Updates" in the "Details" dialog; the button just stays gray. Are PATA drives with SATA adapters verboten in Fedora? Should I try again in one week with Fedora 19 Gnome?

edit retag flag offensive close merge delete

Comments

"Packagekit could have hung."

Wouldn't the process be killed after rebooting a few times? I find it difficult to believe that the problem could continue to occur reboot after reboot.

baroquequest gravatar imagebaroquequest ( 2013-06-26 19:31:15 -0500 )edit

It would, but packagekit would also be restarted every time you logged in. Disable automatic software checking: "Software > click the name in the top panel to bring down menu > sources". I recon if you wait a while and let it run, it will finish. It shouldn't just hang and do nothing.

FranciscoD_ gravatar imageFranciscoD_ ( 2013-06-26 22:33:13 -0500 )edit

Thanks, FranciscoD_. F-18 updates as it should now.

baroquequest gravatar imagebaroquequest ( 2013-07-02 16:29:25 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-06-25 23:04:19 -0500

FranciscoD_ gravatar image

Packagekit could have hung.

In a terminal, try:

$ sudo yum update

If this says there's another PID running, kill that PID using:

$ kill <PID>

and re-run the command.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-06-25 13:40:18 -0500

Seen: 147 times

Last updated: Jun 26 '13