Ask Your Question
1

Kernel won't update - how to fix it?

asked 2013-06-30 03:48:27 -0600

Bucic gravatar image

updated 2017-01-13 15:46:10 -0600

mattdm gravatar image

3.9.6 is currently available (for days) and I got it updated the last time I did system update on my another install of Fedora. However, on my primary install of Fedora I'm stuck with 3.9.4.

What can I do to fix this? Why did it happen?
sudo yum clean all; sudo yum update
No Packages marked for Update

Related + some details
https://ask.fedoraproject.org/question/27266/how-to-change-grub-2-boot-order/

edit retag flag offensive close merge delete

Comments

In a terminal run: sudo yum clean all; sudo yum update and please tell us what happens. Can you also run fpaste --sysinfo and update your question with the link the command returns?

FranciscoD_ gravatar imageFranciscoD_ ( 2013-06-30 04:44:31 -0600 )edit
1

@FranciscoD_ I've updated the original answer.

Bucic gravatar imageBucic ( 2013-06-30 06:18:47 -0600 )edit

It's possible you're hitting an out of sync mirror. Can you try disabling the fastest-mirror plugin etc. and retry? sudo yum clean all; sudo yum --disableplugin=fastestmirror update should do it. Are you using some proxy, or a local mirror or something too?

FranciscoD_ gravatar imageFranciscoD_ ( 2013-06-30 08:00:23 -0600 )edit

Still No Packages marked for Update. I don't use any proxies, local mirrors etc. At least not that I know of. In short, I haven't fiddled with my yum sources configuration, ever.

Bucic gravatar imageBucic ( 2013-06-30 10:11:22 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
3

answered 2013-06-30 17:18:43 -0600

hedayat gravatar image

I think your kernel IS updated, and you are probably booting an older kernel while having the latest kernel installed. run rpm -qa kernel and see which kernel packages are installed.

edit flag offensive delete link more

Comments

kernel-3.9.6-200.fc18.x86_64 This seems to be the case. It also seems that both of my recent questions related to kernels and grub config are about the same source problem. No solutions though.

Bucic gravatar imageBucic ( 2013-07-01 17:32:37 -0600 )edit

I think THIS question is solved (or actually, it is void). Your kernel is updated. You should just boot the correct boot entry.

hedayat gravatar imagehedayat ( 2013-07-02 14:15:36 -0600 )edit

@hedayat The boot entry you speak of is NOT available. Nothing in both of my questions regarding problems with grub/kernel update solves the situation so even though I marked this answer there is no way I will mark any existing answer to the other question (Change boot GRUB order) as it's not even close to answered. Good thing F19 got released. Otherwise I would be stuck with 3.9.4 kernel on F18.

Bucic gravatar imageBucic ( 2013-07-03 12:44:53 -0600 )edit

Hi! I wonder if I've missed the last comment. Have you solved the grub menu issue? Have you tried updating grub.cfg using grub2-mkconfig? :P

hedayat gravatar imagehedayat ( 2014-07-23 16:27:00 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-06-30 03:48:27 -0600

Seen: 51,430 times

Last updated: Jan 13 '17