English
Ask Your Question
1

Lifebook UH572 Touchpad not working in Fedora 19

asked 2013-07-07 22:43:15 +0000

maxcell gravatar image

Hello there, I just got a Fujitsu Lifebook UH572 and managed to install Fedora 19 (after some weird UEFI problems because of Win8/Fedora dual boot). The problem I'm facing now is that the touchpad won't work at all. I've spent a lot of time googling for this, but the only thing I found was the problem that two-finger-scrolling doesn't work. Actually I would be happy, if this would be my only problem ;-)

Sadly I don't have a clue where to look for problems that maybe cause this. I can just give you some information on my system. So first of all the Touchpad section in System Preferences is shown and I can adjust some settings, but without effect. And this is the output of xinput list:

$ xinput list
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=13   [slave  pointer  (2)]
⎜   ↳ BTMOUSE                                   id=14   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Fujitsu FUJ02E3                           id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Fujitsu FUJ02B1                           id=9    [slave  keyboard (3)]
    ↳ Power Button                              id=10   [slave  keyboard (3)]
    ↳ FJ Camera                                 id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]

If you have any idea for solving this, please let me know. If additional information is needed I will provide it asap.

Thanks in advance!

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
1

answered 2013-07-14 14:35:30 +0000

maxcell gravatar image

I finally found a solution. (If someone else ever has the same problem) It is stated here (sorry could not post the link due to my low karma... I found the solution in the blog of Ozgur. The title of the post is: "Ubuntu 12.10 (Quantal Quetzal) on Fujitsu LIFEBOOK UH572") to put in the two kernel parameters into your grub command line args: "i8042.notimeout i8042.nomux"

Then simply run a "sudo grub2-mkconfig" After rebooting the touchpad worked properly. Even tapping und scroll gestures work as expected.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Stats

Asked: 2013-07-07 22:43:15 +0000

Seen: 2,368 times

Last updated: Jul 14 '13