Ask Your Question
2

Black screen after upgrade to kernel 3.10?

asked 2013-07-31 03:46:56 -0500

Timur Kristóf gravatar image

updated 2013-08-21 00:34:26 -0500

Hi,

I did a fresh install of Fedora 19 on an Asus Zenbook UX31A. It worked fine until I upgraded the kernel to version kernel-3.10.3-300.fc19.x86_64, if I boot with this kernel, I get an empty black screen on the laptop. I can still boot the previous kernel 3.9.5-301.fc19.x86_64 but can't figure out what's wrong with the new one.

I haven't installed any non-free kernel modules and don't have any akmods installed. The laptop has an Intel graphics device which is integrated in the Intel Core i7 3517U CPU. It doesn't have switchable graphics or any other graphics card. Secure boot is disabled.

Please note that the problem is that the screen is black. It is illuminated properly and I can even use the brightness keys to change it. Whatever brightness I set, it doesn't affect the fact that the screen remains entirely black. Not even plymouth appears.

Here is what I have tried so far:

  • Boot into runlevel 3 without the rhgb and quiet kernel parameters: resulted in the same problem.
  • Installed dracut-nohostonly and ran dracut -f --regenerate-all to see if it helps. It didn't.
  • Tried a newer kernel kernel-3.11.0-0.rc3.git0.2.fc20.x86_64 which has the exact same issue; EDIT: kernel-3.11.0-0.rc5.git0.2.fc20.x86_64 also has the issue
  • Tried to disable fast boot, but it didn't have any effect.
  • Some searching on the internet suggested that disabling VT-d might help, but it didn't.
  • Tried to suspend and resume the machine after boot. The issue persists.
  • If I use the nomodeset kernel parameter, the system boots but X can't start
  • I can change the brightness, but the screen remains entirely black

Other than the above issue, when I boot with kernel 3.10 the system seems to start correctly, I can even SSH in and look around. Only the screen is black, blank.

It would be great if someone could help me figure out what's wrong.

Thanks in advance for your help! :)

Update + workaround

After looking through some answers, I found a combination of tweaks that will result in a workaround which doesn't completely eliminate the problem but at least makes it possible to use the newest kernel.

  1. In the BIOS settings, enable the Launch CSM option.
    CSM stands for Compatibility Support Mode which in theory allows non-EFI software to boot - seems that there's more to it than that, but I'm not entirely sure how it's related to this problem.
  2. If the screen is not illuminated properly on bootup, add acpi_backlight=vendor to your kernel parameters. (3.11 worked for me without it)
    This parameter did not work correctly with 3.9.5 for me, but it'll still allow 3.10 to boot at least. When trying 3.11.0-0.rc6.git0.2.fc20.x86_64 this parameter was unnecessary.

NOTE: After this workaround, it seems that Gnome's backlight ... (more)

edit retag flag offensive close merge delete

Comments

I'm not an expert on this, but this sounds like some video driver issue. nomodeset basically tells the kernel not to load the video drivers when booting the machine, so it makes sense that you are able to boot with this parameter set. Maybe someone more knowledgeable might be able to help you if you post some error messages that you are getting. Try starting X, wait until black screen, then go to another console screen (ctrl + alt + F2), login and type journalctl (http://0pointer.de/blog/projects/journalctl.html) and post the output here.

dikkeduif gravatar imagedikkeduif ( 2013-07-31 06:16:24 -0500 )edit

I have the same issue. I noticed that an external screen is working. Unfortunately it is only an extended scree, so I do not see any panels. Turning the notebook display on and off doesn't help either (via system settings). Further I noticed that the notebook screen works until X is started (the text based info when booting up is visible).

ingensill gravatar imageingensill ( 2013-07-31 13:42:01 -0500 )edit

Yes, I experience the same thing.

Timur Kristóf gravatar imageTimur Kristóf ( 2013-08-01 04:51:07 -0500 )edit

@dikkeduif - if I boot the system with nomodeset then X doesn't start at all. If I boot it without nomodeset then I can't switch to another console with Ctrl+Alt+F2, the screen remains black.

Timur Kristóf gravatar imageTimur Kristóf ( 2013-08-01 04:52:21 -0500 )edit

Same issue with Asus S550C ultrabook, no akmods, just open stock drivers. After upgrading kernel to 3.10 it seems to freeze on a black screen, but if I boot in verbose mode all seems to be normal and every control is [OK]

output of lspci | grep VGA

00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09) 01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 635M] (rev a1)

iGenius gravatar imageiGenius ( 2013-08-01 20:47:44 -0500 )edit

8 Answers

Sort by » oldest newest most voted
2

answered 2013-08-17 16:55:03 -0500

johann gravatar image

updated 2013-08-18 09:50:51 -0500

I found that I had to do two things in the BIOS to get the 3.10 kernel to boot up properly:

  1. Enable "Launch CSM"
  2. Disable "Secure Boot Control"

I think the disabled CSM is somehow to blame for the dark screen, but even if you enable it on the Asus zenbook prime, it will be automatically disabled if you have the secure boot control enabled.

edit flag offensive delete link more

Comments

I'll give this one a try. Do you know what "Launch CSM" is?

Timur Kristóf gravatar imageTimur Kristóf ( 2013-08-20 15:36:58 -0500 )edit

Seems that the combination of enabling Launch CSM and acpi_backlight=vendor produces a working workaround :)

Timur Kristóf gravatar imageTimur Kristóf ( 2013-08-20 15:54:48 -0500 )edit

Googled it and CSM means Compatibility Support Mode

Timur Kristóf gravatar imageTimur Kristóf ( 2013-08-20 15:57:53 -0500 )edit
2

answered 2013-08-04 17:36:28 -0500

lakerssuperman gravatar image

https://bbs.archlinux.org/viewtopic.php?pid=1306907#p1306907

Similar thread in the Arch forums about this issue. I am an openSUSE user, but we all have the same issue. Hopefully, we can get a work around or fix soon.

edit flag offensive delete link more
1

answered 2013-07-31 14:33:01 -0500

Artur Szymczak gravatar image

updated 2013-08-04 08:10:42 -0500

I have similar problem, and I filled bug report: https://bugzilla.redhat.com/show_bug.cgi?id=989763 (rhbz#989763) Have you tryied to change brightness?

edit flag offensive delete link more

Comments

Yes, I tried to change the backlight and the screen is illuminated, yes, but it remains fully black.

Timur Kristóf gravatar imageTimur Kristóf ( 2013-08-01 04:50:42 -0500 )edit
1

answered 2013-08-18 23:03:09 -0500

umtapao gravatar image

updated 2013-08-18 23:13:53 -0500

How to fix

add acpi_backlight=vendor to grub boot parameter in /etc/grub2.cfg

  1. edit file: /etc/grub2.cfg
  2. find the kernel module parameter line, should be like ..
    linux /vmlinuz-3.10.7-200.fc19.x86_64 root=/dev/mapper/fedora-root ...
  3. add kernel module parameter acpi_backlight=vendor

Example:

linux   /vmlinuz-3.10.7-200.fc19.x86_64 root=/dev/mapper/fedora-root ro rd.lvm.lv=fedora/swap rd.md=0 rd.dm=0 vconsole.keymap=us  rd.luks=0 vconsole.font=latarcyrheb-sun16 rd.lvm.lv=fedora/root rhgb quiet LANG=en_US.UTF-8 i915.i915_enable_rc6=1 pcie_aspm=force drm.vblankoffdelay=1 i915.semaphores=1 acpi_osi='!Windows 2012' acpi_backlight=vendor

It will tell the Linux to use /sys/class/backlight/intel_backlight instead of /sys/class/backlight/acpi_video0

Fix for future kernel installation

In file `/etc/default/grub`, add `acpi_backlight=vendor` in `GRUB_CMDLINE_LINUX`

Example:

GRUB_CMDLINE_LINUX="rd.lvm.lv=fedora/swap rd.md=0 rd.dm=0 vconsole.keymap=us $([ -x /usr/sbin/rhcrashkernel-param ] && /usr/sbin/rhcrashkernel-param || :) rd.luks=0 vconsole.font=latarcyrheb-sun16 rd.lvm.lv=fedora/root rhgb quiet add_efi_memmap i915.i915_enable_rc6=1 pcie_aspm=force drm.vblankoffdelay=1 i915.semaphores=1 acpi_osi='!Windows 2012' acpi_backlight=vendor"

Note

However, the keyboard backlight still malfunction after kernel boot (you can fix it manually by modprobe asus-nb-wmi but I won't say about the details here)

edit flag offensive delete link more

Comments

Hi, my backlight doesn't work when acpi_backlight=vendor is set.

Timur Kristóf gravatar imageTimur Kristóf ( 2013-08-20 15:36:20 -0500 )edit

Ok, it seems that the combination of acpi_backlight=vendor and enabling Launch CSM will make it work more or less, although backlight control doesn't work in Gnome anymore

Timur Kristóf gravatar imageTimur Kristóf ( 2013-08-20 15:51:31 -0500 )edit

acpi_osi='!Windows 2012' doesn't make a difference for me. Why do you need add_efi_memmap?

Timur Kristóf gravatar imageTimur Kristóf ( 2013-08-20 15:59:21 -0500 )edit

other parameters doesn't involve, just only acpi_backlight=vendor

umtapao gravatar imageumtapao ( 2013-08-29 21:00:54 -0500 )edit
0

answered 2013-08-05 20:13:41 -0500

m.p.kingsley gravatar image

I think what may be happening is a bug with the switchable graphics. By any chance, have you tried to blacklist either the intel or nouveau modules?

edit flag offensive delete link more

Comments

Hi, this laptop doesn't have switchabe graphics, only the Intel device.

Timur Kristóf gravatar imageTimur Kristóf ( 2013-08-06 17:52:53 -0500 )edit
0

answered 2013-08-07 10:07:57 -0500

Check to see if your monitor/display is detected. I had similar problem on desktop with old RGB monitor. After upgrade to F19 was only getting black screen after X started.

Do yum install monitor-edid and then run monitor-edid. I was getting 'Bad data' which makes sense with an RGB monitor. Couldn't find a way around the problem other than swapping monitor.

edit flag offensive delete link more

Comments

Hi, thanks for the answer! monitor-edid correctly finds out about my monitor.

Timur Kristóf gravatar imageTimur Kristóf ( 2013-08-10 14:20:32 -0500 )edit
0

answered 2013-08-05 11:51:29 -0500

I didn't get this issue but when I have updated my kernel to 3.10 version I have found some crashes after doing hibernation . It was crashed on some pci drivers (using lenovo 580G). and now i see there are another people with different version of linux have this problem. It was solved simply by coming back using 3.8 kernel version. Already for a few days i got no problem. I think there are still some bugs in 3.10 so maybe in few months it will be repaired just wait and then start using it !!!

edit flag offensive delete link more

Comments

I've downgraded to 3.9, but this is just a workaround, not a solution.

Timur Kristóf gravatar imageTimur Kristóf ( 2013-08-06 17:54:57 -0500 )edit
0

answered 2013-08-13 01:07:04 -0500

I have an asus ux31A with the same issues with 3.10.5 and 3.10.4 - haven't troubleshot it until today.

running: systectl restart gdm fixes it, so I added it to root's cron

@reboot /bin/systemctl restart gdm

-William V

edit flag offensive delete link more

Comments

Hi William, thanks for your answer! Could you please elaborate on this solution? I'm unfamiliar with cron.

Timur Kristóf gravatar imageTimur Kristóf ( 2013-08-13 01:56:55 -0500 )edit

sure, as the root user or via sudo just type:

crontab -e

then add this line to the crontab

@reboot /bin/systemctl restart gdm

This would restart gdm right after you boot up, it is ugly but it gets the job done on my laptop, and the issue is simple enough that I don't feel looking into it further.

-William Verdugo

William V gravatar imageWilliam V ( 2013-08-13 12:51:17 -0500 )edit

Thanks for the details! Unfortunately, this doesn't work for me. Seems that the issue is deeper than what a GDM restart could fix.

Timur Kristóf gravatar imageTimur Kristóf ( 2013-08-14 02:10:09 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2013-07-31 03:46:56 -0500

Seen: 11,284 times

Last updated: Aug 21 '13