English
Ask Your Question
1

tapping in touchpad doesn't work at login in fedora19

asked 2013-08-14 06:49:44 +0000

scow gravatar image

updated 2013-08-14 12:57:37 +0000

Using Fedora 19.

At login screen, I am able to navigate but unable to click by tapping on to the touchpad to select a username.

The physical clicker at the bottom of touchpad does work so I use that or use the enter to get to the next screen where the system ask for password. At that screen tapping the touchpad does work.

I am using HP Pavilion g series laptop.

edit retag flag offensive close delete

Comments

Just giving you a taste of the correct answer.

The reason is, when you go and change the mouse settings in the settings center, it changes the dconf properties for YOUR SPECIFIC USER.

While some settings (like language) have a option to make it the default for everyone, most settings still do not (will never???) allow that.

You need to find a way to copy your dconf settings to the gdm user. Maybe google can help with that.

Honestly, I just gave us and decided to click that 1 clock in the login screen.

hmaarrfk ( 2013-08-14 07:42:49 +0000 )edit

I rarely use mouse with my laptop, I use the touchpad. I will rearranged my sentences, its a bit heavy :D Anyway, thank you, this is somewhat the first time I use forum in Linux community, and you make me feel welcomed :) Nice info, will be useful for me in the future.

scow ( 2013-08-14 12:54:24 +0000 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2013-08-14 10:19:05 +0000

@hmaarrfk got it right mostly. You should be able to enable the click for the entire system though. Please read up https://fedoraproject.org/wiki/How_to_enable_touchpad_click and see if it helps.

edit flag offensive delete publish link more

Comments

I read your link and bookmark it but haven't read the Official Gnome Instruction. Will let you know, later. Thanks. Note: My touchpad work normally after login. The "touch to click" doesn't work only when choosing username screen and entering the password screen. These 2 screens appear before we enter desktop.

scow ( 2013-09-09 12:39:53 +0000 )edit
0

answered 2013-08-14 14:52:11 +0000

hmaarrfk gravatar image

I'm assuming you are using Gnome Shell (the default with main Fedora spin) able to use the Mouse settings to configure your Touchpad in your logged in user??? Gnome Shell Mouse settings

Let me elaborate on what seems to be FranciscoD_'s link seems to imply that the goto way of doing it is to add a X.org config file that has the mouse configuration. That way will get all the users configured the same.

My experience with it, is that it does give you full flexibility (IMO Gnome Shell is really stripping some necessary options) on the synaptics but you need to experiment quite a bit with it.

Follow the instructions on his link, and you can see a full list of options here http://linux.die.net/man/4/synaptics

If you run the command syndaemon you should see the current of the synaptics options. Most of them are defaults, but a few have been set up by Gnome Shell through the settings interface.

Here is the annoying part: after you set everything up, you will want to disable Gnome Shell from controlling your synpactics touchpad, so that it doesn't keep changing the values you modified back to the values it expects.

I think the GDM already disables gnome shell from controlling the synaptics touchpad, but for your user, you will want to sudo yum install dconf-editor and open dconf-editor through the gnome-shell interface. Then navigate to the option org.gnome.settings-daemon.plugins.mouse and uncheck active. That way, when your user logs in (or actually switches in and out of them main session) it will not overwrite the configuration you worked so hard setting up. Note you will have to do this for every user that wishes to use the global settings. If I recall correctly, the GDM user (the user that manages the login screen) should take these settings without changing anything in dconf. If this isn't true, please post and I'll help you find the answer you are looking for :D.

edit flag offensive delete publish link more

Comments

Yes, I am using gnome. My touchpad work normal "after login". The "touch to click" on touchpad does not work only in two screen after fedora booting up. The first screen is where we asked to select username screen; the second screen is where we asked to input the password. Should I go ahead experimenting with the command above?

scow ( 2013-09-09 12:30:01 +0000 )edit

Your answer

Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

Add answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers to your questions.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Stats

Asked: 2013-08-14 06:49:44 +0000

Seen: 1,055 times

Last updated: Aug 14 '13