Ask Your Question
1

Fedora 19 GNOME : White wallpaper problem

asked 2013-08-25 22:35:43 -0600

moksha gravatar image

updated 2013-08-25 22:57:44 -0600

FranciscoD_ gravatar image

I have recently installed Fedora 19 on a Dell Optiplex 330 system. Everything seems to work nicely except for the wallpaper. Only 2-3 wallpaper can be selected form the list. No other pre-installed wallpapers, no other pictures can be set as wallpaper. Being tries they will show as a pure white desktop background.Is there a way out? Pls. help.

edit retag flag offensive close merge delete

Comments

I had a similar problem on one machine. I’ve no idea why that machine was affected and not any others, but I ‘fixed’ it using GNOME Tweak Tool. In the “Desktop” section, try messing around with the “Picture Options”. No guarantees… ;)

Gareth Jones gravatar imageGareth Jones ( 2013-08-26 09:49:55 -0600 )edit

Update the system with sudo yum update and restart

yanglifu90 gravatar imageyanglifu90 ( 2013-08-26 17:18:14 -0600 )edit

Same problem on a freshly installed machine. Still not solved.

akiross gravatar imageakiross ( 2013-09-09 02:50:34 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2013-09-07 06:53:28 -0600

The following worked for me:

  • go to /usr/share/backgrounds/gnome where the pre-installed wallpapers are stored
  • as root, open the wallpaper of your choice in gimp
  • resize the picture to 1920x1200 pixels
  • save it under a different name
  • choose this new file as your wallpaper using gnome-tweak-tool: Desktop and then URI address of the picture

Apparently, the problem is that some of the wallpapers (most of them actually) have wrong size. After changing it to 1920x1200 pixels, they load up fine.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-08-25 22:35:43 -0600

Seen: 1,878 times

Last updated: Sep 07 '13