English
Ask Your Question
1

My mouse Cursor dissapears when using Gnome3.

asked 2013-08-31 04:36:48 +0000

Sg.Bee gravatar image

updated 2013-08-31 07:00:30 +0000

My mouse Cursor disappears when using Gnome3. I have a touchscreen laptop and also have a mouse connected to it. I can still use the mouse and move it around. I know this because i can see icons flicker as if a mouse was over it. I change Desktops to KDE and don't have a problem with this so its Gnome specific. Any Ideas or suggestions on fixing my Houdini Mouse Cursor?

edit retag flag offensive close merge delete

Comments

Sometimes, when I restart my laptop, I don,t see my mouse. I just reboot it and it seems to work. I would file a bug report but I have no idea what caused it.

hmaarrfk ( 2013-08-31 05:56:52 +0000 )edit

I also used to have this problem about a month ago for a couple of days, on a clean (only Fedora repos) and up to date Fedora 19, Gnome 3, intel integrated graphics, in 2 cases: after reboot https://bugzilla.redhat.com/show_bug.cgi?id=969649 and after screen lock (with gnome-screensaver - Gnome 3 on Fedora 19 is missing manual ctrl+alt+l screen lock feature) https://bugzilla.redhat.com/show_bug.cgi?id=908133 I remember switching to the console (ctrl+alt+f2) and back to the graphical mode (ctrl+alt+f1) was enough to restore the cursor for me, as the first bug says. Is your Fedora up to date?

marcindulak ( 2013-08-31 17:41:20 +0000 )edit

I just updated it and am running the newest Kernel at the moment and i am still having this issue. I think for the moment I will be using a different Desktop Environment. I will look for existing bug. I have noticed that when I have a hunch that openshot video editor might have something to do with it. I am still experimenting with what sets it off so that I can get a better understanding of it.

Sg.Bee ( 2013-09-01 08:23:29 +0000 )edit

4 answers

Sort by ยป oldest newest most voted
1

answered 2014-07-03 15:49:06 +0000

mbmark gravatar image

I had the same problem in Fedora 20. None of the responses here (or that I could find elsewhere) helped. This seems to have fixed it, though:

Open a terminal window and type:

dconf write /org/gnome/settings-daemon/plugins/cursor/active false

I don't know why setting this "false" gives me the mouse and true takes it away, but maybe I just don't understand what "cursor active" means. Anyway, I'm just glad to have the pointer back!

edit flag offensive delete link more
0

answered 2013-09-25 05:15:14 +0000

vdm gravatar image

updated 2013-09-25 05:22:34 +0000

I've hit exactly the same problem! After i've unlocked screen, I see no cursor. but desktop is responsible to mouse button clicks and mouse-over events. If fixed after restart and does not appear again, by current. But - i'm sure it's a kind of sporadic bug. My system is fully up-to-date. Added a comment in bugtracker.

edit flag offensive delete link more
0

answered 2014-01-05 23:10:50 +0000

abustany gravatar image

updated 2014-01-05 23:17:59 +0000

Had the same symptom after upgrading to Fedora 20, I suspect gnome-settings-daemon tries to be smart and hides the cursor on tablets (I have a lenovo laptop with a touchscreen and and trackpad). Disabling the "cursor" plugin of gnome-settings-daemon fixed things for me: install and launch dconf-editor, go to org/gnome/settings-daemon/plugins/cursor and uncheck the "active" checkbox.

edit : see gnome bug 698310 which might also be relevant for the touchscreen cases

edit flag offensive delete link more
0

answered 2014-01-16 19:59:09 +0000

I had the same problem with my vaio pro. Here are what I've done that fix the problem.

1) install dconf-editor

2) open terminal and type

dconf write /org/gnome/settings-daemon/peripherals/touchpad/touchpad-enabled false

then type

dconf write /org/gnome/settings-daemon/peripherals/touchpad/touchpad-enabled true

Your mouse should be working again.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Stats

Asked: 2013-08-31 04:36:48 +0000

Seen: 6,954 times

Last updated: Jul 03 '14