Ask Your Question

fedora 19 reboot loop after fedup

asked 2013-09-07 23:20:27 -0500

formahult gravatar image

updated 2013-09-08 02:56:35 -0500

FranciscoD_ gravatar image

So I originally had live media for fedora 17 long story short I decided to use Fedup to get to fedora 19 rather than downloading fedora 19 media.

I installed f17 with no issues and updated my installation of f17. I then ran

yum --enablerepo=updates-testing install fedup
sudo fedup-cli --network 19

and checked the log file as instructed.

When no issues were found I rebooted to begin the upgrade process. I let it run until the ASCII hotdog guy appeared and the process appeared complete without any problems occurring that I could see. So I hard rebooted and found myself in the grub menu. when I try booting f19 when the fedora icon fills up it immediately reboots. I tried rebooting to f17 which also crashes. I also tried selecting 'fedora linux' in grub which appears to load up crashes and logs out when I try to log in.

I've tried googling, looking through the fedora 19 common bugs area and through the forums here but I can't find much that matches my issue.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted

answered 2013-09-10 14:13:07 -0500

link gravatar image

Seems to be a fedup or drakut issue. To make your system running, you need to edit /boot/grub2/grub.cfg and remove: upgrade plymouth.splash=fedup selinux=0

The reboot loop its because the system don't recognize the upgrade and don't remove that line.

grub.cfg have a warning to don't edit the file, but believe it's the right option. I also started the system in rescue mode with a dvd, I made updates, including kernel updates, but the solution it's the grub.cfg edition.

My grub.cfg have:

BEGIN /etc/grub.d/10_linux

menuentry 'Fedora (3.10.10-200.fc19.x86_64) 19 (Schrödinger’s Cat)' --class fedora --class gnu-linux --class gnu --class os { load_video set gfxpayload=keep insmod gzio insmod part_msdos insmod ext2 set root='(hd0,msdos5)' search --no-floppy --fs-uuid --set=root d869822d-e89d-46f0-b491-f3c0c578d1f3 echo 'Loading Fedora (3.10.10-200.fc19.x86_64) 19 (Schrödinger’s Cat)' linux /boot/vmlinuz-3.10.10-200.fc19.x86_64 root=UUID=d869822d-e89d-46f0-b491-f3c0c578d1f3 ro rd.lvm=0 KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0 LANG=en_US.UTF-8 upgrade plymouth.splash=fedup selinux=0 echo 'Loading initial ramdisk ...'

Just remove "upgrade plymouth.splash=fedup selinux=0" and enjoy your Fedora!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools


Asked: 2013-09-07 23:20:27 -0500

Seen: 1,401 times

Last updated: Sep 10 '13