Ask Your Question
7

How to turn off bluetooth by default?

asked 2013-09-09 07:47:22 -0600

scow gravatar image

updated 2013-09-09 07:50:08 -0600

I am using Fedora 19. How to turn off bluetooth that by default is always on? I want to save my power and I am afraid someone enter my system by way of bluetooth. Its been more than 30 times I turn off bluetooth manually :(

edit retag flag offensive close merge delete

Comments

1

Use tlp. Intructions are given here

florian gravatar imageflorian ( 2015-10-03 09:15:09 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
4

answered 2013-09-09 08:20:34 -0600

Jann5s gravatar image

Apparently, this is not very easy, and hopefully this will improve in future fedora versions. But here is described how you can do it.

edit flag offensive delete link more

Comments

Thank you. It works!

scow gravatar imagescow ( 2013-09-13 14:36:20 -0600 )edit
1

tlp makes it very easy to turn devices on or off at boot or shutdown. Check this one

florian gravatar imageflorian ( 2015-10-03 09:15:28 -0600 )edit
2

answered 2014-01-25 10:10:46 -0600

m8ram gravatar image

updated 2015-10-03 08:09:40 -0600

A simpler way to do this is to disable the bluetooth service. Using rfkill to kill the daemon after it starts works but it is better not to start it at all.

Use systemctl (on Fedora 19 and up) to stop en then disable the service:

sudo systemctl stop bluetooth
sudo systemctl disable bluetooth

For some reason the gnome-bluetooth app still shows the "active" icon but opening the gnome-bluetooth settings screen will show that it is disabled.

edit flag offensive delete link more

Comments

Can you add code tags to your commands ? sudo systemctl stop bluetooth.service ; sudo systemctl disable bluetooth.service . Also for the GNOME applet the user can search for a startup .desktop file inside /etc/xdg/autostart/ or/and ~/.config/autostart/ folders and disable it.

NickTux gravatar imageNickTux ( 2014-01-25 10:48:43 -0600 )edit
0

answered 2017-01-02 13:44:15 -0600

deajan gravatar image

updated 2017-01-02 13:46:34 -0600

Using systemctl stop bluetooth will only disable the daemon, not the actual radio. On Fedora 22 and upwards, you also need to enable rc.local support.

Also, install rfkill with dnf install rfkill if not done already.

Here's how. Create file /etc/rc.d/rc.local with following content: #!/usr/bin/env sh rfkill block bluetooth

Don't forget to chmod the file and enable the rc.local compatibility service.

chmod 755 /etc.rc.local
systemctl enable rc-local
systemctl start rc-local
edit flag offensive delete link more

Comments

Little addition: the content of /etc/rc.d/rc.local should be

#!/usr/bin/env sh

rfkill block bluetooth

exit 0

Otherwise, this is the correct answer. Just can't upvote it yet :)

treba gravatar imagetreba ( 2018-08-21 05:11:31 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-09-09 07:47:22 -0600

Seen: 15,091 times

Last updated: Jan 02 '17