Ask Your Question
0

Pidora httpd unreachable

asked 2013-09-23 04:38:21 -0500

xzibbitist gravatar image

Hello,

I have installed my Raspberry PI yesterday, and found out that loads of the Fedora questions matched my Pidora questions, so I decided to drop my question here as well.

I have Httpd, PHP and MySQL running on my Pidora server, and yesterday i was able to reach it over LAN, WAN and even through my DNS settings on my URL. I plugged the power out of it over night because I don't want to run a data center, just play with my server, and fired it up again this morning.

I didn't check if my httpd starts at boot, but I have started it manually as well. Launched my MySQL (not necessary but I was hoping that would solve my problem).

HTTPD is working, according to my HTTPD status

[root@raspi ~]# service httpd status
Redirecting to /bin/systemctl status  httpd.service
httpd.service - The Apache HTTP Server
      Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled)
      Active: active (running) since Thu, 2013-06-20 14:54:40 EDT; 1min 51s ago
     Process: 1332 ExecStop=/usr/sbin/httpd $OPTIONS -k graceful-stop (code=exited, status=0/SUCCESS)
    Main PID: 1335 (httpd)
      Status: "Total requests: 0; Current requests/sec: 0; Current traffic:   0 B/sec"
      CGroup: name=systemd:/system/httpd.service
          ├ 1335 /usr/sbin/httpd -DFOREGROUND
          ├ 1337 /usr/sbin/httpd -DFOREGROUND
          ├ 1338 /usr/sbin/httpd -DFOREGROUND
          ├ 1339 /usr/sbin/httpd -DFOREGROUND
          ├ 1340 /usr/sbin/httpd -DFOREGROUND
          └ 1341 /usr/sbin/httpd -DFOREGROUND

Jun 20 14:54:38 raspi.local httpd[1335]: AH00558: httpd: Could not reliably ...e
Jun 20 14:54:40 raspi.local systemd[1]: Started The Apache HTTP Server.

However, I cant reach it by going to its IP (192.168.1.252) in my browser, I can reach the SSH (same IP other port). The port settings have not changed over night, so everything should just be working (and locally I don't think port settings matter at all, it worked before forwarding from my LAN network).

What can i do to test what's wrong or to make it work? Thanks.

edit retag flag offensive close merge delete

Comments

In the cases of complicated and often changing setup it's good to document everything you do. Hard to guess what went wrong here, the first thing I would try is systemctl stop firewalld.service

marcindulak gravatar imagemarcindulak ( 2013-09-23 15:37:39 -0500 )edit

"AH00558: httpd: Could not reliably" is also a hint ...

marcindulak gravatar imagemarcindulak ( 2013-09-24 02:14:07 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2013-09-24 03:43:05 -0500

xzibbitist gravatar image

Hi,

I have figured out the problem, it was indeed the firewalld. Thanks for the comment on that mistake. I did not solve it completely but made a temporary change by removing firewalld and using iptables with the allowance of port 80.

I also know the warning/error message is about a server name, that has something to do with dns. It was not necessary to be solved, but i did by changing the httpd.conf file and set my server dns in there.

Thanks all!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-09-23 04:38:21 -0500

Seen: 1,178 times

Last updated: Sep 24 '13