English
Ask Your Question
1

Black Windows in Gnome 3 (suddenly)

asked 2013-09-25 11:52:32 +0000

Jmlevick gravatar image

updated 2014-09-30 20:06:31 +0000

mether gravatar image

I've been having this problem for a while now; The problem is, when I'm using GTK apps such as GIMP or Firefox, suddenly these apps start to have black menus and sub windows, and then, when I open other app, such app it's fully black. Restarting the shell results in a GNOME crash, so I have to either log out with "Ctrl + Alt + Backspace" or reboot the computer to get normal apps again. A screenshot of the problem:

http://commondatastorage.googleapis.com/jmstorage%2FEngBlack.png

I don't know what might be causing this, and it's completely random as far as I've experienced. I do not have propietary drivers installed on this system, my lspci it's here: https://gist.github.com/Jmlevick/843bbe330d0e758415ab

Kernel: 3.11.1-200.fc19.x86_64 (fedora 19)

Any ideas?

edit retag flag offensive close merge delete

Comments

Thanks, that seems relevant to this issue. What I don't know is if I have to create a 10-intel.conf as the guy that reports that bug or a 20-intel.conf as the ArchWiki recommends. Also I'm not sure if my card it's compatible with SNA or I have to set that option to UXA. For the moment, I'll create the same file as the one in the bug report and test to see if the problem dissapears. In the meantime I'll be waiting for more answers :)

Jmlevick ( 2013-09-25 18:59:47 +0000 )edit

the actual name of the file does not matter; any *.conf files in /etc/X11/xorg.conf.d/ will be included.

randomuser ( 2013-10-19 20:41:24 +0000 )edit

Yep, someone already told me at bugzilla ;)

Jmlevick ( 2013-10-20 00:21:26 +0000 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2013-10-19 16:48:36 +0000

Jmlevick gravatar image

As marcindulak pointed out in a comment, this bug report it's relevant for the issue, and a fix it's posted there:

https://bugzilla.redhat.com/show_bug.cgi?id=961781

I'll tell you what to do:

1) su -  
2) touch /etc/X11/xorg.conf.d/10-intel.conf    
3) gedit /etc/X11/xorg.conf.d/10-intel.conf

and in that file we have to put te following:

Section "Device"
    Identifier "Intel Graphics"
    Driver "intel"
    Option "AccelMethod" "sna"
EndSection

We save, reboot and problem solved! at least in my case. There are some cards where the SNA acceleration method it's not supported, so if you still having the problem after this, just change "sna" for "uxa" in the file we've just created.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Stats

Asked: 2013-09-25 11:52:32 +0000

Seen: 3,308 times

Last updated: Oct 19 '13