Ask Your Question
0

Start VPN on Fedora 19 boot?

asked 2013-09-26 05:05:23 -0500

steve gravatar image

updated 2013-09-27 00:15:01 -0500

FranciscoD_ gravatar image

Hello,

I'd like to connect with my VPN client when my Fedora 19 boots. Where do I find the settings for that? (I'm using an OpenVPN connection)

There has been an option for that as I could see on this screenshot docs.fedoraproject.org/en-US/Fedora/17/html/System_Administrators_Guide/images/Network_Configuration_NM_Editing-VPN-connection-1_Gnome3.png

Thanks

edit retag flag offensive close merge delete

Comments

Thanks, but it still doesn't show up. I've found the /etc/NetworkManager/system-connections/my_vpn File, where information about my connections are saved (I don't know why it's not an .ovpn file but I don't know much about OpenVPN). I added autoconnect=true at the second line, but still, doesn't connect on startup :/

steve gravatar imagesteve ( 2013-09-26 17:46:51 -0500 )edit

There are sample startup scripts in the openvpn package,but I don't know how it works, I never used it before.

skytux gravatar imageskytux ( 2013-09-26 18:15:43 -0500 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2013-09-26 16:32:54 -0500

skytux gravatar image

Open the settings with the following command:

$ nm-connection-editor

Then click Add to create a new connexion, or click on an existing one.

HTH,

Germán.

edit flag offensive delete link more

Comments

1

Thanks, this worked for me. For some reason the default GNOME network settings window does not have the "automatically connect to VPN when using this connection" checkbox where it should.

kappa gravatar imagekappa ( 2015-05-12 05:40:20 -0500 )edit

Please vote if it worked for you :-)

skytux gravatar imageskytux ( 2015-05-12 14:19:32 -0500 )edit
0

answered 2013-11-04 18:45:44 -0500

steve gravatar image

updated 2013-11-05 15:59:28 -0500

I've solved the problem. Open terminal, enter nmcli con list -> you get a list of all your VPN connections. Copy the UUID of the one you want to start on boot, and run this code: nmcli con up uuid XXXXXXX-XXX-XXXXX (the XXX... represent your UUID)

This should (re-)connect to your VPN. If this works, insert the code into the last line (if there is any content) of your /etc/rc.local with sudo gedit /etc/rc.local

Restart, and after a few seconds (or a minute) you'll be connected automatically.

I don't know whether this is a pretty solution, but at least it is a solution!

Edit: ok, does not work properly, maybe it is because the OpenVPN service isn't started when the command is executed, I don't know...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-09-26 05:05:23 -0500

Seen: 2,205 times

Last updated: Nov 05 '13