English
Ask Your Question
3

Boot fedora 20 from iso

asked 2013-09-26 19:22:46 +0000

kas gravatar image

updated 2013-09-27 05:16:46 +0000

Hi.. I can't boot fedora 20 iso file from HDD ? since the structure of fedora 20 iso file has changed, what i need to change in menu entry ? Thanks..

this is the menuentry for fedora 19:

menuentry "Fedora ISO" {
insmod loopback
set root='hd0,msdos7'
loopback loop (hd0,7)/boot/fedora.iso
linux (loop)/isolinux/vmlinuz0 iso-scan/filename=/boot/fedora.iso root=live:CDLABEL=Fedora-Live-MATE-Compiz-i686-19- rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0
initrd (loop)/isolinux/initrd0.img
}
edit retag flag offensive close merge delete

Comments

The CDLABEL is ISO filename without .ISO.

Charles Wang ( 2013-11-28 04:57:40 +0000 )edit

5 answers

Sort by » oldest newest most voted
2

answered 2013-11-25 01:41:27 +0000

Thermionix gravatar image

updated 2014-02-08 14:12:30 +0000

I couldn't get it to boot with the hd:LABEL copied from the isolinux.cfg

So retrieve the partition UUID from the iso by booting the iso and typing ls -l /dev/disk/by-uuid/ into the dracut emergency shell, and note the uuid for use in the below grub entry

The following config works for me for the netinstaller

menuentry "Fedora-20-x86_64-netinst.iso" {
    set iso_path="/iso/Fedora-20-x86_64-netinst.iso"
    loopback loop $iso_path
    linux (loop)/isolinux/vmlinuz inst.stage2=hd:UUID="2013-12-12-14-06-38-00" noeject iso-scan/filename=$iso_path
    initrd (loop)/isolinux/initrd.img
}
edit flag offensive delete link more

Comments

The UUID of the harddisk’s partition can be obtained by ls -l /dev/disk/by-uuid/

erik ( 2013-12-10 17:01:23 +0000 )edit

sudo lsblk -f and sudo blkid are usefull commander.

Charles Wang ( 2013-12-31 05:56:28 +0000 )edit
1

answered 2014-12-27 23:40:00 +0000

Solitary Angler gravatar image

Hi,

Thanks for your comments, I finally got grub2 to boot Fedora 21 Workstation ISO latest version (64bits Fedora-Live-Workstation-x86_64-21-5.iso). Thanks to hedayat's comments to look for the CD label inside isolinux.cfg (it is different from the alpha version), I got the commands right. Am adding it here for reference.

Thanks,

Solitary Angler

menuentry "Fedora 21 Live Workstation x86_64" --class fedora {
  set isoname="Fedora-Live-Workstation-x86_64-21-5.iso"
  set isopath="/PATH-TO-FILE/"
  set isofile="${isopath}/${isoname}"
  echo "Using ${isoname}..."
  loopback loop (hd0,7)$isofile
  linux (loop)/isolinux/vmlinuz0 iso-scan/filename=${isofile} root=live:CDLABEL=Fedora-Live-WS-x86_64-21-5 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0
  initrd (loop)/isolinux/initrd0.img
}
edit flag offensive delete link more
0

answered 2013-11-24 14:12:07 +0000

Charles Wang gravatar image

I need it!

edit flag offensive delete link more

Comments

haha, I got it! the code is follow: menuentry "Boot Fedora 20 LiveCD" --class Fedora Linux { insmod loopback set root=(hd0,9) set iso_path="/Fedora/Fedora20.iso" loopback loop (hd0,9)/$iso_path linux (loop)/isolinux/vmlinuz0 iso-scan/filename=$iso_path root=live:CDLABEL=Fedora-Live-Desktop-i686-20-TC2 rootfstype=auto ro quiet rd.live.image noeject rhgb rd.luks=0 rd.md=0 rd.dm=0 initrd (loop)/isolinux/initrd0.img }

Charles Wang ( 2013-11-26 12:58:12 +0000 )edit
0

answered 2013-11-25 11:35:09 +0000

Charles Wang gravatar image

thanks, but how to know the ISO file UUID?

edit flag offensive delete link more
0

answered 2014-09-25 22:15:34 +0000

Hi kas! Thank you for the good question, which actually showed me how to boot Fedora 21 Workstaion live ISO as easy as possible. This is my working menu entry:

menuentry "Fedora 21 ISO" {
        insmod loopback
        set root='hd0,msdos8'
        loopback loop (hd0,8)/tmp/Fedora-Live-Workstation-x86_64-21_Alpha-1.iso
        linux (loop)/isolinux/vmlinuz0 iso-scan/filename=/tmp/Fedora-Live-Workstation-x86_64-21_Alpha-1.iso root=live:CDLABEL=Fedora-Live-Workstation-x86_64-2 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0
        initrd (loop)/isolinux/initrd0.img
}

The root= option is copied verbatim from isolinux/isolinux.cfg inside iso, and it works fine. I wonder what your problem is. Maybe you've not used the correct label? Anyway, thank you for the question! :)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
2 followers

Stats

Asked: 2013-09-26 19:22:46 +0000

Seen: 9,694 times

Last updated: Dec 27 '14