Ask Your Question
0

Problem with flash plugin and media playing software

asked 2013-10-01 19:16:22 -0500

Hagen23 gravatar image

updated 2013-10-02 10:09:35 -0500

Every time I try to play a youtube video while another media player application is running (tried rhythmbox, banshee and vlc), the flash player crashes. To play the video, I have to close the media player and reload the window. It also happens the other way around: if I am playing a youtube video, I can not start any kind of media in the media player. I have to close the window that has the video in order to play anything.

I don't know where to search or what to do, any help will be appreciated.

I'm attaching some information about my system. I'll provide more if needed.

Thanks.

  • Fedora 17

  • uname -a

3.8.13-100.fc17.x86_64 #1

  • lspci | grep -i audio

00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA) 01:00.1 Audio device: nVidia Corporation GF104 High Definition Audio Controller (rev a1)

  • lspci | grep -i VGA

01:00.0 VGA compatible controller: nVidia Corporation GF104 [GeForce GTX 460] (rev a1)

  • rpm -aq | grep gstream*

gstreamer-tools-0.10.36-1.fc17.x86_64 gstreamer-python-0.10.22-2.fc17.x86_64 gstreamer-plugins-bad-free-0.10.23-8.fc17.x86_64 gstreamer-plugins-base-0.10.36-2.fc17.x86_64 gstreamer-plugins-ugly-0.10.19-1.fc17.x86_64 gstreamer-plugins-good-0.10.31-4.fc17.x86_64 gstreamer-0.10.36-1.fc17.x86_64 gstreamer-plugins-bad-0.10.23-1.fc17.x86_64 phonon-backend-gstreamer-4.6.3-1.fc17.x86_64

  • rpm -aq | grep flash

flash-plugin-11.2.202.251-release.x86_64

  • rpm -aq | grep rhythm

rhythmbox-2.97-1.fc17.x86_64

  • rpm -aq | grep vlc

vlc-core-2.0.8-2.fc17.x86_64 vlc-2.0.8-2.fc17.x86_64

  • rpm -aq | grep banshee

banshee-musicbrainz-2.4.1-1.fc17.x86_64 banshee-2.4.1-1.fc17.x86_64

  • rpm -aq | grep firefox

firefox-22.0-1.fc17.x86_64

dmesg | tail -20

[ 20.979643] Bluetooth: Core ver 2.16

[ 20.979703] NET: Registered protocol family 31

[ 20.979705] Bluetooth: HCI device and connection manager initialized

[ 20.979715] Bluetooth: HCI socket layer initialized

[ 20.979717] Bluetooth: L2CAP socket layer initialized

[ 20.979722] Bluetooth: SCO socket layer initialized

[ 21.008823] Bluetooth: BNEP (Ethernet Emulation) ver 1.3

[ 21.008828] Bluetooth: BNEP filters: protocol multicast

[ 21.008842] Bluetooth: BNEP socket layer initialized

[ 22.121176] NVRM: Your system is not currently configured to drive a VGA console

[ 22.121181] NVRM: on the primary VGA device. The NVIDIA Linux graphics driver

[ 22.121183] NVRM: requires the use of a text-mode VGA console. Use of other console

[ 22.121185] NVRM: drivers including, but not limited to, vesafb, may result in

[ 22.121186] NVRM: corruption and stability problems, and is not supported.

[ 22.773123] r8169 0000:02:00.0 p10p1: link up

[ 22.773144] IPv6: ADDRCONF(NETDEV_CHANGE): p10p1: link becomes ready

[ 32.393125] fuse init (API version 7.21)

[ 32.395880] SELinux: initialized (dev fuse, type fuse), uses genfs_contexts

[ 32.441818] SELinux: initialized (dev fusectl, type fusectl), uses genfs_contexts

[ 58.606772] SELinux: initialized (dev sdc1, type fuseblk), uses genfs_contexts

Edit-- Added /var/log/messages. It appears to be a sound related issue.

Oct 2 08:59:00 HagenF-PC pulseaudio[1482]: [alsa-sink] alsa-sink.c: Error opening PCM device front:0: Device or resource busy

Oct ... (more)

edit retag flag offensive close merge delete

Comments

I don't know what your RAM or CPU endowment is, but it's possible that simultaneously playing something in a browser w\ the Flash plugin and playing audio, or especially video, in a standalone media player might be overwhelming your processor. Playing video is very demanding of a system's resources. Also, the Flash plugin has a reputation for being buggy, and if you're using Firefox, my experience w\ that browser is that it's a CPU hog.

hawkfeather gravatar imagehawkfeather ( 2013-10-01 21:23:25 -0500 )edit

Hmm I don't think that's the problem. I have an AMD Phenom II 810 Processor 2.60GHz, with 4GB of RAM. I also have a windows partition where that problem does not happen. The only hardware component that may cause this is the Nvidia card... But I can't really tell...

Hagen23 gravatar imageHagen23 ( 2013-10-01 22:09:49 -0500 )edit

FIrst of all, Fedora 17 is unsupported, so if it is a bug, you don't get any updates. So you should try install latest version of Fedora and test it again. But to not leave you with unsolved question, could you post dmesg | tail -20 when crash happend?

none gravatar imagenone ( 2013-10-02 02:33:13 -0500 )edit

Sure. Here it is: dmesg | tail -20 [ 20.979643] Bluetooth: Core ver 2.16 [ 20.979703] NET: Registered protocol family 31 [ 20.979705] Bluetooth: HCI device and connection manager initialized [ 20.979715] Bluetooth: HCI socket layer initialized [ 20.979717] Bluetooth: L2CAP socket layer initialized [ 20.979722] Bluetooth: SCO socket layer initialized [ 21.008823] Bluetooth: BNEP (Ethernet Emulation) ver 1.3 [ 21.008828] Bluetooth: BNEP filters: protocol multicast [ 21.008842] Bluetooth: BNEP socket layer initialized [ 22.121176] NVRM: Your system is not currently configured

Hagen23 gravatar imageHagen23 ( 2013-10-02 09:00:28 -0500 )edit

[ 22.121176] NVRM: Your system is not currently configured to drive a VGA console [ 22.121181] NVRM: on the primary VGA device. The NVIDIA Linux graphics driver [ 22.121183] NVRM: requires the use of a text-mode VGA console. Use of other console [ 22.121185] NVRM: drivers including, but not limited to, vesafb, may result in [ 22.121186] NVRM: corruption and stability problems, and is not supported. [ 22.773123] r8169 0000:02:00.0 p10p1: link up [ 22.773144] IPv6: ADDRCONF(NETDEV_CHANGE): p10p1: link becomes ready [ 32.393125] fuse init (API version 7.21) [ 32.395880] SELinux:

Hagen23 gravatar imageHagen23 ( 2013-10-02 09:02:15 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-10-02 09:22:21 -0500

maramyfriend gravatar image

Try using gnash

sudo yum install gnash gnash-plugin Restart your browser and all should be fine

You may want to try removing your current Adobe flash player

edit flag offensive delete link more
0

answered 2013-10-19 12:55:49 -0500

Hagen23 gravatar image

I updated the Nvidia driver to version 319.60 and it fixed the problem both in fedora 17 and 19.

Thanks for your feedback.

edit flag offensive delete link more

Comments

Forgot to mention that I also upgraded to kernel kernel-3.9.10-100.fc17.x86_64

Hagen23 gravatar imageHagen23 ( 2013-10-19 13:12:53 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-10-01 19:16:22 -0500

Seen: 1,073 times

Last updated: Oct 19 '13