English
Ask Your Question
1

How to change boot selection theme in fedora 19

asked 2013-10-21 16:02:56 +0000

nks gravatar image

I've installed fedora 19 i686 kde edition (dual boot with windows 7 X86), when I boot my pc it gives two os to choose fedora19 and windows 7. That's ok......

Now this grub boot selection theme is so boring it is black like DOS and only 5 sec to choose os.

I'm looking for changing the boot selection theme and also selection time. I just want some colorful theme and os selection time upto 10 sec.

Please help me!!!!!!!!!!

i'll be highly obliged if anyone response. Thank you............

edit retag flag offensive close delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2013-10-21 16:53:33 +0000

nonamedotc gravatar image

There is a nice starry theme in Fedora repository for grub. Do

yum install grub2-starfield-theme

Once you have this add the following line, with appropriate changes, to /etc/default/grub

GRUB_THEME=full_path_to_theme_file

Typically, the full path should be /boot/grub2/themes/<theme_name>/theme.txt

Now, to change the time interval, simply edit the /etc/default/grub -

GRUB_TIMEOUT=10

This value should, by default, be 5.

After making these changes, run

grub2-mkconfig -o /boot/grub2/grub.cfg
edit flag offensive delete publish link more
0

answered 2013-10-21 16:48:00 +0000

maarten gravatar image

updated 2013-10-21 16:52:36 +0000

Everything is explained on the GRUB page on the https://wiki.archlinux.org/index.php/GRUB (Arch Linux wiki).

To apply a change to the GRUB boot menu, you need to rebuild the grub.cfg file.

10 seconds OS selection time in GRUB:

Modify GRUB_TIMEOUT in /etc/default/grub:

$ sudoedit /etc/default/grub

Modify

GRUB_TIMEOUT=5

to

GRUB_TIMEOUT=10

Use a theme

Install starfield theme:

$ sudo yum install grub2-starfield
$ sudoedit /etc/default/grub

Add this line (again: no spaces between the '='):

GRUB_THEME="/usr/share/grub/themes/starfield/theme.txt"

Comment the following line, add a '#' character before it):

GRUB_TERMINAL_OUTPUT="console"

becomes

#GRUB_TERMINAL_OUTPUT="console"

More options for modification are listed on the Arch wiki

Rebuild the grub config (Apply the changes made in /etc/default/grub)

This section assumes you have only 1 GRUB boot loader installed!

First, locate your grub.cfg file:

$ GRUBCFG=$(sudo find /boot -name "grub.cfg")

Next, rebuild your grub.cfg:

$ sudo grub2-mkconfig -o "$GRUBCFG"
edit flag offensive delete publish link more

Your answer

Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

Add answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers to your questions.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question tools

Follow
1 follower

Stats

Asked: 2013-10-21 16:02:56 +0000

Seen: 967 times

Last updated: Oct 21 '13