English
Ask Your Question
1

How to upgrade to Fedora 20 using FedUp?

asked 2013-10-22 12:39:21 +0000

Faisal Aslam gravatar image

updated 2014-04-14 20:15:46 +0000

mether gravatar image

I want to upgrade to Fedora 20. I have currently installed Fedora 19. I searched on Google and I know about Fedup. How can we use Fedup to upgrade Fedora 19 to Fedora 20. Please tell me about it. First I use this method

# yum install fedora-release-rawhide
# yum-config-manager --disable fedora updates updates-testing
# yum-config-manager --enable rawhide
# cp fedora-rawhide.repo fedora-rawhide-updates.repo

# mkdir StableRepo
# mv fedora.repo  fedora-updates.repo fedora-updates-testing.repo StableRepo/

# vi fedora-rawhide.repo
[rawhide]
name=Fedora - Rawhide - Developmental packages for the next Fedora release
failovermethod=priority
baseurl=http://fedora.mirror.nexicom.net/linux/development/20/x86_64/os/
##baseurl=http://download.fedoraproject.org/pub/fedora/linux/development/$basearch/os/
##mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=rawhide&arch=$basearch
enabled=1
gpgcheck=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch

# vi fedora-rawhide-updates.repo
[rawhide-update]
name=Fedora - Rawhide - Developmental packages for the next Fedora release
failovermethod=priority
baseurl=http://fedora.mirror.nexicom.net/linux/updates/testing/20/x86_64/
##baseurl=http://download.fedoraproject.org/pub/fedora/linux/development/$basearch/os/
##mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=rawhide&arch=$basearch
enabled=1
gpgcheck=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch

# yum update -y  yum
# rpm -qa | grep yum 
yum-3.4.3-106.fc20.noarch

# yum distro-sync
# yum remove gnome-shell-*
# yum distro-sync --skip-broken -y 

# rpm -e highlight pyliblzma  rtkit --nodeps
# rpm -e --nodeps ilmbase-1.0.3-5.fc19.i686

# rpm -e --nodeps ilmbase
# reboot 
# yum install -y gdm 
# yum install gnome-shell-*
# reboot

I failed. Then I use this method

After installing Fedup, I run this command

# sudo fedup-cli --network 19
edit retag flag offensive close delete

Comments

1

Rawhide is *not Fedora 20! You do not want to run on rawhide unless you have the experience required to make it work. You should disable the Rawhide repo and run a yum distro-sync before you attempt the fedup command as suggested by @cobra.

randomuser ( 2013-10-22 14:41:18 +0000 )edit

7 Answers

Sort by ยป oldest newest most voted
3

answered 2013-10-22 12:45:34 +0000

You should be able to use

fedup --network 20

from the root command line - you might need to enable the testing repositories first, but it looks like you might have done that (your post is difficult to read).

edit flag offensive delete publish link more

Comments

1

Because F20 is a prerelease at this point, fedup users might have to specify an installation repo by URL. Using the testing repo probably isn't required - but since you're using an alpha/beta, you may as well test packages and give karma too, right?

randomuser ( 2013-10-22 14:43:20 +0000 )edit

@randomuser It worked flawlessly for me, just with the fedup --network 20

Bucic ( 2013-12-04 19:58:15 +0000 )edit
0

answered 2013-12-20 14:20:23 +0000

boubakr92 gravatar image

Update your system

$ sudo yum update -y

Option 1. Using Internet

$ sudo fedup --network 20

Option 2. Using ISO file

$ sudo fedup --iso /path/to/iso-file

Reboot your OS:

$ reboot
edit flag offensive delete publish link more
0

answered 2013-12-06 09:30:57 +0000

Having installed FedUp, this worked for me:

 sudo fedup-cli --network 20
edit flag offensive delete publish link more
0

answered 2013-12-20 14:24:04 +0000

mithrial gravatar image

Use fedora-upgrade.

# yum install fedora-upgrade
# fedora-upgrade

For me, this worked pretty fine.

edit flag offensive delete publish link more
0

answered 2013-12-30 13:16:00 +0000

I have a slow internet connection. I cannot download Fedora 20 from terminal. I have to download it from some downloader. Tell me if I can disable update repo and create a new repo of USB so it only check my USB for Fedora 20 files, use them and upgrade my computer to Fedora 20.

edit flag offensive delete publish link more

Comments

Please open a new question.

randomuser ( 2013-12-30 16:19:36 +0000 )edit
-1

answered 2014-03-04 15:00:09 +0000

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2014-03-04 15:00:09 +0000

It's very, very simple make upgrade Fedora 19 to Fedora 20, just:

Install the new Fedora 20 gpg key and upgrade:

rpm --import https://fedoraproject.org/static/246110C1.txt

Then:

yum update yum

And:

yum clean all

To finish:

yum --releasever=20 distro-sync

edit flag offensive delete publish link more
-1

answered 2013-12-18 02:30:04 +0000

cloudbuster gravatar image

updated 2013-12-20 01:38:43 +0000

how about a straightforward list of operations

to install fedup and Fedora 20

rawhide just makes everything an enormous mess

why mess with gnome

what a mess

I don't see a yum install fedup anywhere

I remember doing a yum install fedup when I installed Fedora 19

guess I'll just wait until 2014

edit flag offensive delete publish link more

Comments

[root@localhost ~]# yum install fedup Loaded plugins: langpacks, refresh-packagekit Package fedup-0.7.3-4.fc19.noarch already installed and latest version Nothing to do [root@localhost ~]# yum distro-sync Loaded plugins: langpacks, refresh-packagekit No packages marked for distribution synchronization [root@localhost ~]# fedup-cli --network 19 setting up repos... default-installrepo/metalink | 21 kB 00:00:00
default-installrepo

cloudbuster ( 2013-12-18 02:41:52 +0000 )edit

I envy the newbies trying to make this work..how bout some coherent instructions

cloudbuster ( 2013-12-18 02:42:56 +0000 )edit

[root@localhost ~]# yum install fedup Loaded plugins: langpacks, refresh-packagekit Package fedup-0.7.3-4.fc19.noarch already installed and latest version Nothing to do [root@localhost ~]# yum distro-sync Loaded plugins: langpacks, refresh-packagekit No packages marked for distribution synchronization [root@localhost ~]# fedup-cli --network 19 setting up repos... default-installrepo/metalink | 21 kB 00:00:00
default-installrepo

cloudbuster ( 2013-12-18 02:44:20 +0000 )edit
1

I think the solution I gave carried the simplest, most effective of instructions. Why would we ever want to make this look waay more complicated than it is? This questioner never reported that fedup wasn't installed... if they had, then a further reply like the one you added would have been made. Seeing as how the solution worked, and was one line, we have all the complexity we need.

cobra ( 2013-12-18 09:58:24 +0000 )edit

hodgepodge of instructions=============================================================================================================================================================

Package Arch Version Repository Size

Updating: fedup noarch 0.8.0-3.fc19

cloudbuster ( 2013-12-20 01:33:22 +0000 )edit

Your answer

Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

Add answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers to your questions.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Stats

Asked: 2013-10-22 12:39:21 +0000

Seen: 6,438 times

Last updated: Mar 04