Ask Your Question
1

Fedora 19 stopped working after nvidia drivers?

asked 2013-10-23 09:47:20 -0500

Radioactivity gravatar image

updated 2014-03-18 08:10:57 -0500

mether gravatar image

Hello! I am a linux user and i made the adventurous journey of switching from debain-based operating system to RedHat-based operation systems. In this case.. Fedora 19! In linux mint and ubuntu i was used to finding the drivers in the settings. Where i could simply press on the driver i want , wait a little then reboot. But in fedora i couldn't find that. So i went to RPM fusion and followed the steps. I installed the nvidia driver and rebooted. BAM. It displays a lot of text and never happens to boot into gnome ( UI ) I last used the command su yum update yesterday. How can i fix fedora? Also there is what i suspect to be a previous kernel. In the boot menu there is fedora with the latest kernel. Fedora with what i think was the previous kernel. None of them work.... I GREATLY appreciate any help. Thank you for reading and triple thank you for answering.

edit retag flag offensive close merge delete

5 Answers

Sort by ยป oldest newest most voted
1

answered 2013-10-23 10:08:06 -0500

cobra gravatar image

If you can boot to a command line and log in as root then you can fix this. From the command line you need to remove the nvidia drivers - with 'yum remove kmod-nvidia'. Double-check that no xorg.conf files have been left hanging around in /etc/X11 then reboot.

It is possible that that your video card isn't in the batch supported by the latest nvidia drivers. It might help to visit the nVidia website and work through the 'download drivers' until it tells you which package matches your video chipset. Then go back to yum and see if there is a kmod-nvidia-... package that matches and install it.

If the latest drivers are what is needed, then you might have to uninstall or disable the nouveau driver before it'll work correctly. Also there is an nvidia configuration tool you can run, which might help it select the right driver and pick the correct screen resolution.

edit flag offensive delete link more

Comments

You can clear out everything nVidia related, and nothing else, with one command, done as root: yum remove *nvidia*

sideburns gravatar imagesideburns ( 2013-10-24 01:06:33 -0500 )edit
1

answered 2013-11-05 18:55:39 -0500

rfchapman gravatar image

updated 2013-11-05 22:35:07 -0500

I had the same issue, but I re-installed Fedora 19. When I installed either kmod-nvidia-304xx or akmod-nvidia-304xx, I would get an error that the nvidia.so could not be found. The GUI would just flash then go away.

I checked to make sure the nouveau driver was being blacklisted etc... I also ran "akmods --kernels $(uname -r)" which gave me a huge clue. It told me that it could not find the kernel sources in order to build the driver.

I then ran "yum install kernel-devel" and then re-ran "akmods --kernels $(uname -r)" which then built/installed the nvidia driver.

I then ran "modprobe nvidia" and it loaded the module without error.

I think the akmod and kmod RPMS should both require that kernel-devel should be installed for the kernel that you are using. That would save everyone a lot of time.

Hope this helps.

edit flag offensive delete link more
0

answered 2014-03-18 07:18:42 -0500

panchtatvam gravatar image

First you need to verify if your grapphics card has Nvidia Optimus (either you can see for NVIDIA Optimus logo on your laptop or you can check this from your laptop manufacturer specification page) or is it impossible to turn off (which is not even needed) the Intel driver / NVIDIA Optimus from BIOS . To check this use

lspci |grep -i VGA

You are a candidate of this resolution if you get something like (I'm too an Optimus "Prime" holder :P )

00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF119M [GeForce 610M] (rev ff)

Just follow the Bumblebee Project for your Fedora version and you should be good to go. It will use the stock NVIDIA driver blob. I suggest to install both the Bumblebee (with nouvea drivers) and Bumblebee with NVIDIA proprietary drivers. This way the shared optimus technology will work best. Installing Primus also won't do any harm. After you reboot, the OS will use NVIDIA whenever needed as per the Optimus technology.

edit flag offensive delete link more
0

answered 2013-10-23 10:08:19 -0500

Rajat gravatar image

Install nVidia proprietary drivers for GeForce 6/7/8/9/200/300/400/500/600/700 series cards

yum localinstall http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm

akmod-nvidia for GeForce 8/9/200/300/400/500/600/700 series cards & akmod-nvidia-304xx for GeForce 6/7 series cards kmod-nvidia for GeForce 8/9/200/300/400/500/600/700 series cards kmod-nvidia-304xx for GeForce 6/7 series cards

yum install akmod-nvidia xorg-x11-drv-nvidia-libs akmod-nvidia-304xx xorg-x11-drv-nvidia-304xx-libs kmod-nvidia xorg-x11-drv-nvidia-libs kmod-nvidia-304xx xorg-x11-drv-nvidia-304xx-libs

edit flag offensive delete link more
0

answered 2013-10-23 11:12:30 -0500

Radioactivity gravatar image

cobra. How can i boot into command line? And my video card IS supported by the latest nvidia drivers :).. Where is that nvidia configuration tool??

edit flag offensive delete link more

Comments

1

There are several ways to get into the command line, if your video drivers aren't working, then they usually fail and it drops you into a command line after they time out. If that doesn't work, try rebooting and editing the kernel arguments from the grub menu, pop a 3 at the end of the kernel line after all the other parameters, that should boot you up into runlevel 3, which (for Fedora and RedHat systems) is full multi user mode with networking but no X.

cobra gravatar imagecobra ( 2013-10-23 11:19:22 -0500 )edit
1

As far as the configuration tool, I must confess that I can't remember what it's called. I used to use it from the Gnome menu - but now my system has an ATI video chipset (which seems to be much better supported on Linux at the moment) so I don't even have it installed. From memory it's called something like 'nvidia-config', and I remember that it might need to installing separately to the video drivers - if so it'll be in the rpmfusion repository somewhere. If it's not installed already you should be able to find it in yumex.

cobra gravatar imagecobra ( 2013-10-23 11:23:10 -0500 )edit

I could not find no kernel in grub :/

Radioactivity gravatar imageRadioactivity ( 2013-10-23 13:13:36 -0500 )edit

I took the time to take a picture of what appears on the screen with my ipad though

Radioactivity gravatar imageRadioactivity ( 2013-10-23 13:14:00 -0500 )edit

http://i1331.photobucket.com/albums/w591/grim3322/IMG_0536_zps22ef266d.jpg

Radioactivity gravatar imageRadioactivity ( 2013-10-23 13:14:07 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-10-23 09:47:20 -0500

Seen: 6,261 times

Last updated: Mar 18 '14