Ask Your Question
2

can not find fedora 19 after reinstalling windows 7

asked 2013-10-26 06:57:07 -0500

nks gravatar image

updated 2014-09-27 16:53:11 -0500

mether gravatar image

I used to dual boot fedora 19 (20 GB ext4) and windows 7 (60 GB NTFS). I reinstall window 7 in the 60 GB NTFS drive during some problem occurs to windows. After installing windows 7 i do not found fedora 19 for boot. When i start my machine it directly boot to the windows 7 (not os selection given).

I've a live usb of fedora 19, when i boot that usb i can see the fedora 19 (20 GB ext4) drive.

Please tell me a way to boot that fedora 19 (20 GB ext4) with windows 7.

I'll be higly obliged if anyone reply. Thank you!!!!!!!!!!

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
5

answered 2013-10-26 09:23:54 -0500

Marc lml gravatar image

This is how you can restore Grub with a default Fedora 19 installation. Grub will recognize your Windows 7 installation.

Boot from the live DVD and open a terminal as root. First use fdisk -l to identify your partitions.

This example is from a system that uses default partitioning of Fedora 19.

[root@localhost ~]# fdisk -l

Disk /dev/mapper/live-rw: 8589 MB, 8589934592 bytes, 16777216 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/mapper/live-osimg-min: 8589 MB, 8589934592 bytes, 16777216 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/sda: 21.5 GB, 21474836480 bytes, 41943040 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk label type: dos
Disk identifier: 0x0003948c

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048     1026047      512000   83  Linux
/dev/sda2         1026048    41943039    20458496   8e  Linux LVM

Disk /dev/mapper/fedora-swap: 2164 MB, 2164260864 bytes, 4227072 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/mapper/fedora-root: 18.8 GB, 18782093312 bytes, 36683776 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Use this output for the following commands.

mkdir /mnt/root
mount /dev/mapper/fedora-root /mnt/root
mount /dev/sda1 /mnt/root/boot/
mount -o bind /dev /mnt/root/dev
mount -o bind /proc /mnt/root/proc
mount -o bind /sys /mnt/root/sys
mount -o bind /run /mnt/root/run
chroot /mnt/root
grub2-install --no-floppy --recheck /dev/sda
grub2-mkconfig -o /boot/grub2/grub.cfg
exit
/sbin/shutdown -r now
edit flag offensive delete link more

Comments

Funciona, muchas gracias.

adiazc87 gravatar imageadiazc87 ( 2014-12-11 15:44:07 -0500 )edit

Thank you, this how to is very useful. This is still a pain to share his system with Windows...

nicofonk gravatar imagenicofonk ( 2016-12-03 01:59:24 -0500 )edit
0

answered 2013-10-26 08:58:22 -0500

rickhg12hs gravatar image

One other option is to edit the Windows Boot loader. "EasyBCD" http: //neosmart.net/EasyBCD/ really does make this easy.

Asinine karma restrictions prevent me from making a real URL, so you'll have to delete the space between the colon (:) and the slash (/).

edit flag offensive delete link more
0

answered 2013-10-26 07:04:02 -0500

Bharat gravatar image

updated 2013-10-26 07:11:56 -0500

Windows installation resets the MBR (Master Boot Record) so you wont be able to see your linux partitions. That is why the usual practice is to install windows and then linux. But it is not a big problem. You will have to reinstall grub (the linux boot loader) to the MBR using a live CD. Check the page mentioned below. It is quite informative.

http: //www.av8n.com/computer/htm/grub-reinstall.htm

edit flag offensive delete link more

Comments

remove the space between http: and // .. i had to do it because i was not able to post it

Bharat gravatar imageBharat ( 2013-10-26 07:04:59 -0500 )edit

hope it works for me. Thank you!!!!!!!!!!1

nks gravatar imagenks ( 2013-10-26 07:50:44 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-10-26 06:57:07 -0500

Seen: 17,207 times

Last updated: Dec 11 '14