Ask Your Question
0

Fedora 19: /etc/resov.conf auto-renewed!!

asked 2013-11-14 21:49:53 -0500

dynamic_joe gravatar image

updated 2014-02-14 22:45:04 -0500

mether gravatar image

Out of the box my Fedora 19 installation has just one line in /etc/resolv.conf, which is "nameserver 192.168.1.1". Ping works, firefox/yum etc not working. By adding "nameserver 8.8.8.8" to /etc/resolv.conf as root, the problem solved, that is, I can browse the web normally.

The trouble is, each time I reboot the machine, or wake the machine up from suspending, the /etc/resolv.conf automatically changed back to "nameserver 192.168.1.1" and I had to do the manual edit again.

In Fedora 16, 17 or ubuntu there were no such trouble. BTW 192.168.1.1 is my router.

Any help? Thanks.

edit retag flag offensive close merge delete

Comments

Sorry I can help you, but I have nameserver 192.168.0.1 in my /etc/resolv.conf, which is also the IP of my wireless router, and I can browse internet normaly.

skytux gravatar imageskytux ( 2013-11-14 23:21:03 -0500 )edit

4 Answers

Sort by ยป oldest newest most voted
1

answered 2013-11-15 00:54:08 -0500

msmahmood gravatar image

Look for "network connection" or "network configuration" in System settings. When you open it, select the interface you are using and then in the field of DNS/nameserver type 8.8.8.8. That should do the trick, because every time you restart the computer, it restart the "Network-Manager" and that pulls the nameservers form "network connection" utility and stores it into resolv.conf

Hope that helps.

edit flag offensive delete link more
0

answered 2013-11-16 06:18:15 -0500

Marc lml gravatar image

You can change the network options to achieve the same goal, without the /etc/resolv.conf being overwritten at every boot.

  • Go to System Settings > Network
  • Select your interface and click Options...
  • Choose the tab IPv4 Settings
  • Change the method from Automatic (DHCP) to Automatic (DHCP) addresses only
  • At "DNS servers" fill in: 8.8.8.8, 8.8.4.4
edit flag offensive delete link more
0

answered 2013-11-15 17:27:48 -0500

Hi: You /etc/resolv.conf should have a line something like

# Generated by NetworkManager

Meaning that everything there is going to be wiped on every restart (which you're seeing) . As @msmahmood says you need to edit your configuration on your Network Manager settings in order to make persistent.

Kind regards

edit flag offensive delete link more
0

answered 2013-11-15 16:11:16 -0500

Rabin gravatar image

As @skytux says, something is misconfigured in your router, I recommend resetting your router to its factory settings - seems your router is not performing recursive DNS queries.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-11-14 21:49:53 -0500

Seen: 2,132 times

Last updated: Nov 16 '13