Ask Your Question
1

no valid kits found

asked 2013-11-18 04:07:55 -0500

SaeedMasoumi gravatar image

updated 2014-09-12 19:59:26 -0500

mether gravatar image

hi i have installed qt-creator in my F19. wehn i want to create a new qt project it gives me this error

no valid kits found

How do I fix it

thanks?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-11-18 14:54:35 -0500

Marc lml gravatar image

Please go to Tools->Options->Build & Run->Kits and set up one kit to use. At least fill in the device type, device (most likely desktop) as well as the tool chain and debugger. For qmake-based projects you will also need a qt version and mkspec (which can be empty if you are ok with the default one).

You might need to define Qt versions and tool chains first (other tabs on the same options page).

Creator needs this information to know how to parse your compile output and debug the results.

Source: Tobias Hunger on http://qt-project.org

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-11-18 04:07:55 -0500

Seen: 2,368 times

Last updated: Nov 18 '13