Ask Your Question
0

Please help, Fedora won't boot?

asked 2013-12-16 15:17:21 -0600

Andy gravatar image

updated 2014-09-28 15:25:35 -0600

mether gravatar image

I have installed Fedora on a the same disk as a Windows 8. When the installation process was complete, I restarted the system and tried booting into Fedora, but I get this error:

Windows failed to start. A recent hardware or software change might be the cause.
To fix the problem:

  1. Insert your Windows installation disc and restart the computer.
  2. Choose your language settings, and click "Next."
  3. Click "Repair your computer."

If you do not have this disc, contact your system administrator or computer 
manufacturer for assistance.

    File: \NST\AutoNeoGrub2.mbr

    Status: 0xc000007b

    Info: The application or operating system couldn't be loaded because a  
          required file is missing or contains errors.

(screenshot)

What can I do to fix this issue?

Windows 8 is the factory OS, and I don't have its original CD.

edit retag flag offensive close merge delete

Comments

I see nobody is commenting - hopefully you can still boot windows. I must say that i don't have any uefi experience (apart from setting BIOS into legacy mode), but this (http://askubuntu.com/questions/230878/dual-boot-windows-8-and-ubuntu-with-windows-8-boot-manager) suggests that have you already experimented with other bootloaders than grub? I would rather start with installing Fedora in hyper-v or virtualbox. Due to uefi pain + the performance of virtual machines today i would avoid dual boots, or try first Ubuntu - they have many good docs

marcindulak gravatar imagemarcindulak ( 2013-12-18 15:03:56 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2014-04-11 03:09:55 -0600

abadrinath gravatar image

EasyBCD does NOT work. Everyone says it does, but NO.

I did the exact same mistake. It cannot detect it.

Get rid of EasyBCD's new entry from Windows, and then go into Fedora using the Boot Menu (if needed)

#OPTION 1

add this to the /etc/grub.d/40_custom file

menuentry 'Microsoft Windows 8.1' {
           set root='hd0,gptX'
           chainloader /EFI/Microsoft/Boot/bootmgfw.efi
           boot
}

Replace X with the sda number of partition /boot/efi This should work.

OPTION 2

If this does not work, go into the BIOS Options using F12. some computers have different keys.|

Go to boot and change the boot priority so that Fedora is first. Then, if you want to boot into Windows, you have to switch the boot priority again.

Hope I helped! :)

PS: Easy bcd doesn't work because it doesn't support gpt disks

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-12-16 15:17:21 -0600

Seen: 900 times

Last updated: Apr 11 '14