Ask Your Question
0

Microphone does not work

asked 2013-12-28 09:19:07 -0500

jpriskin gravatar image

updated 2013-12-28 11:18:06 -0500

I'm running Fedora 19 using LXDE. Since certain time the microphone did not work, it used to work, I suppose some update caused an issue. I haven't tried it for a while so I don't know exactly what happened, but it's SW issue definitely (see below for Live boot trial I made). The application where I need a microphone is Skype. I tried to record an input stream via:

$ arecord rec.wav

$ aplay rec.wav

but there is a silence at the speakers. The sound outpu works properly both in Skype and in aplay.

The issue is the same for several (two) users I have. I tried to reboot to some older kernels, but it was the same. I looked the /var/log/boot.log and dmesg, but nothing reasonable found.

Finally, I tried to boot using Fedora19 Live with KDE which I had on the USB flash. There were no issue with microphone, I tried arecord and aplay example from above and it worked fine.

Info

jpriskin@labrador:/home/jpriskin:$ uname -a

Linux labrador 3.12.5-200.fc19.x86_64 #1 SMP Tue Dec 17 22:21:14 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

jpriskin@labrador:/home/jpriskin:$ lspci | grep -i audio

00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 01)

jpriskin@labrador:/home/jpriskin:$ rpm -qa | grep -iE "alsa|pulse"

pulseaudio-module-x11-3.0-10.fc19.x86_64

alsa-lib-1.0.27.2-1.fc19.i686

pulseaudio-libs-3.0-10.fc19.x86_64

pulseaudio-libs-3.0-10.fc19.i686

alsa-firmware-1.0.27-1.fc19.noarch

alsa-utils-1.0.27.2-2.fc19.x86_64

alsa-lib-1.0.27.2-1.fc19.x86_64

pulseaudio-utils-3.0-10.fc19.x86_64

pulseaudio-libs-glib2-3.0-10.fc19.x86_64

pulseaudio-3.0-10.fc19.x86_64

alsa-plugins-pulseaudio-1.0.27-1.fc19.x86_64

alsa-tools-firmware-1.0.27-2.fc19.x86_64

jpriskin@labrador:/home/jpriskin:$ systemctl status alsa-state

alsa-state.service - Manage Sound Card State (restore and store)

Loaded: loaded (/usr/lib/systemd/system/alsa-state.service; static)

Active: active (running) since Sat 2013-12-28 15:28:29 CET; 2h 44min ago

Main PID: 400 (alsactl)

CGroup: name=systemd:/system/alsa-state.service

      -400 /usr/sbin/alsactl -s -n 19 -c -E ALSA_CONFIG_PATH=/etc/alsa/alsactl.conf --initfile=/lib/alsa/init/00main rdaemon
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-12-29 12:36:12 -0500

jpriskin gravatar image

updated 2013-12-29 12:38:26 -0500

Issue solved, mistakenly I had muted all capture devices. It was enough to un-check the item in pavucontrol, alsamixer or whatever.

Please close the issue.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-12-28 09:19:07 -0500

Seen: 3,665 times

Last updated: Dec 29 '13