English
Ask Your Question
1

"Fedora logo" displayed after suspend/resume

asked 2014-01-03 08:54:14 +0000

dhekir gravatar image

updated 2014-10-01 04:19:43 +0000

mether gravatar image

After performing a suspend/resume cycle, the screen displays only the Fedora logo (as in during the boot process). I see the mouse pointer and can move it, but I cannot interact with any other process in my X session.

The machine seems to be running normally, I can Ctrl+Alt+F2 to login into a terminal and use it normally: ps indicates processes are still running, including X, etc., but when trying to launch any graphical application, the process just hangs as if waiting for the screen, and nothing else happens until I kill it via Ctrl+C. Doing Ctrl+Alt+F1 returns to the screen with the Fedora logo and nothing more.

If I kill the X process, then the login screen is displayed again and I can use my computer normally. Is there a way to restore my graphical session without killing X?

Or, more precisely: which application is responsible for displaying the Fedora logo? Is it the X process itself? It seems as if I could "kill" it, the other processes might be "visible" again, but I find no information about what is drawing this logo on my screen.

Notes: I upgraded from Fedora 18 to 20, formatting the root partition but not the home partition. I had some issues with the DISPLAY variable but couldn't find anything specific about them. I had never had an issue with Fedora 18.

Edit: After some tests, I do not know the exact cause of the error. If I suspend my machine, wait a few seconds and resume it, the error does not happen. On the other hand, it happened once without suspend/resume, after doing a Ctrl+Alt+F2 to another terminal and returning to the first one. A weird thing is that, even when I cannot see the screen (only the Fedora logo), the mouse pointer turns into a "text cursor" in some parts of the screen, as if the underlying application were still there.

edit retag flag offensive close merge delete

Comments

I see this issue too. I've brought it up on the Fedora testing list but we haven't been able to isolate the cause of this behaviour yet. The worst part is that it doesn't happen each time and therefore it's more difficult to debug. :(

FranciscoD_ ( 2014-01-04 08:21:08 +0000 )edit

That's plymouth, you can tell it to stop with 'plymouth --quit', I am not sure this would let the graphical desktop show up though, you can try it.

If you don't care much about boot splash/screens, you can disable plymouth altogether by adding 'plymouth.enable=0' to the kernel command line (and remove 'rhgb quiet' if you want to see the boot messages).

Ahmad Samir ( 2014-01-04 11:44:36 +0000 )edit

Naw. It's more an X/nouveau/kernel issue I think. but yeah, not enough info to decide yet.

FranciscoD_ ( 2014-01-04 12:45:51 +0000 )edit

I have this issue with ThinkPad t430 with Nvidia NVS 5400M 2GB graphic card, with Fedora 20. Is there any solution?!!!

Mohammad Emami ( 2014-01-08 15:29:43 +0000 )edit

I'm experiencing the same symptoms here. I tried debugging the problem using these instructions: fedoraproject.org/wiki/Common_kernel_problems?rd=KernelCommonProblems#Suspend.2FResume_failure

All I get after seeing the Fedora logo again is this:

[    1.236514]   hash matches drivers/base/power/main.c:647
[    1.236517]  ep_81: hash matches
[    1.236520]  ep_81: hash matches
[    1.236522]  ep_81: hash matches
[    1.236523]  ep_81: hash matches

ep_81 seems to have to do something with USB - maybe a problem with the USB kernel module?

[root@daedalus ~]# find / -name ep_81
/sys/devices/pci0000:00/0000:00:14.0/usb3/3-1/3-1:1.0/ep_81
/sys/devices/pci0000:00/0000:00:14.0/usb3/3-0:1.0/ep_81
/sys/devices/pci0000:00/0000:00:14.0/usb4/4-0:1.0/ep_81
/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1:1.0/ep_81
/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-0 ...
(more)
johnassel ( 2014-01-12 10:12:21 +0000 )edit

3 answers

Sort by ยป oldest newest most voted
0

answered 2014-01-16 04:46:03 +0000

ckujau gravatar image

I too was curious what program was presenting this "Fedora logo" screen and maybe @AhmadS is on to something, plymouth did run when this logo screen was on and it's not running usually. While the logo screen was on, I switched to the textconsole and saved an output of "ps auxww", then I did "init 3 && init 5" and saved another output. After omitting the unintersting stuff, the following programs were not running any more:

$ diff ps.before ps.after
5d4
<  /bin/dbus-daemon --config-file=/etc/at-spi2/accessibility.conf --nofork --print-address 3
103a103
>  /usr/lib64/tumbler-1/tumblerd
108d107
<  /usr/libexec/at-spi2-registryd --use-gnome-session
111,113d109
<  /usr/libexec/bluetooth/bluetoothd
<  /usr/libexec/dconf-service
<  /usr/libexec/gconfd-2
116,117d111
<  /usr/libexec/gvfsd-http --spawner :1.3 /org/gtk/gvfs/exec_spaw/1
<  /usr/libexec/gvfsd-metadata
143d136
<  @usr/sbin/plymouthd --mode=boot --pid-file=/var/run/plymouth/pid --attach-to-session
156a150
>  xscreensaver -no-splash

I was impressed to see that it is possible in Fedora 20 to "yum remove plymouth" I did just that, maybe it helps something.

edit flag offensive delete link more

Comments

plymouth is added to the kernel initramfs, so after uninstalling plymouth I think you need to regenerate the initramfs with 'dracut -f'.

Ahmad Samir ( 2014-01-18 05:42:38 +0000 )edit

Here it seems as if removing plymouth helped. For three days I haven't seen the logo after suspend yet!

johnassel ( 2014-01-21 07:29:10 +0000 )edit
0

answered 2014-05-10 18:34:17 +0000

Jukka gravatar image

I removed plymouth with "yum remove plymouth" And laptop is now recovering from sleep nicely. :)

IBM T60p 3.14.2-200.fc20.i686 #1 SMP Mon Apr 28 15:01:48 UTC xfce4-power-manager [AMD/ATI] RV530/M56 GL [Mobility FireGL V5200]

edit flag offensive delete link more
0

answered 2014-01-19 04:48:24 +0000

Jadi gravatar image

same problem on Fedora20. Moved the hard disk to a new laptop (from ATI to INTEL graphic card) and that happenend again. Shouldnt be related to the graphic card.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
2 followers

Stats

Asked: 2014-01-03 08:54:14 +0000

Seen: 1,228 times

Last updated: May 10 '14